Rescuezilla has identical i/o errors with multiple USB drives

I have tried to image the internal NVMe drive using Rescuezilla, but I have failed. I have two external USB 2T drives connected. The backup failed to the first external drive twice. I cannot get most of the utilities to launch in Rescuezilla so I was unable to save the stack trace. The final line says ErrNo 5 - I/O error. Each time the following files were copied to the USB drive before the error happened:
After two tries with USB drive 1, I switched to USB 2T drive 2, but exactly the same thing happened. The above files were copied, then an ErrNo 5 occurred. Both drives had 2 terabytes available. I tried and failed to launch all of the included apps except for filemanager, imageviewer and devicelist which did launch. I got rescuezilla from the rescuezilla website. On the chance that the error was on the internal NVMe storage device, I examined the SMART data using the nvme utility. No errors were reported. Can you suggest something more that I can try in order to get this drive imaging to work?

While I recommend Rescuezilla for my family members who do not appreciate CUI, I myself use Clonezilla since the day one I deviated from Windows.

It can backup any file format as long as it is running on Intel/AMD CPUs.

For me it indicates USB connection problem.

@Aravisian @StarTreker do you have any idea?

Yes, or bad iso file (corruption in file) or bad drive.

1 Like

Yeah, I don't recommend putting backups on pen drives, I don't think FLASH reliability is good enough for something that serious. I recommend buying a 128GB external SSD USB drive. They can be bought for not a whole lot of money, but will cost more then pen drives, but the point is, they are far more realiable!

Most SSD drives require at least 2TB of writes or more to them, before they begin to have issues. And your not going to do that by placing backups on them a few times.

1 Like

I use this with SSD/HDD.
I never backup to USB key.

Much cheaper than purchasing an external SSD/HDD in enclosure.

USB keys are good only for temporary storage and file exchange purposes. I never trust them as a backup drive.

OMG, thats from our favorite guys at Inatek!

Office Space Reaction GIF by MOODMAN

Just don't buy a printer from them!

office space GIF by 20th Century Fox Home Entertainment

Thanks everyone for your comments. The two drives I was using are conventional 2T hard drives. I have decided to buy another very compact 2T USB hard drive such as the 2 that I have been using for Backup and Timeshift. I admit I am somewhat skeptical about a USB connection issue since I attempted the Rescuezilla imaging 3 times and exactly the same files were copied before the i/o error occurred. Still, it's best to eliminate that as a possibility ... so as soon as I get my car out of the garage (having repairs), I will get another new USB drive. As to the non-functioning parts of my Rescuezilla memory stick, I will download the iso file again to see if a bad iso file was the problem. However, no errors were reported during the first download. Thanks again.

Did you verify the checksum of the rescuezilla .iso before using it? :wink:

1 Like

There doesn't seem to be a checksum available on the rescuezilla website, so no I didn't.

Be earnest with you, I never bother checking it myself.
I still think the problem you faced was due to the fact you were trying to use USB key as a backup drive.

You are correct - after some searching I found this:

I was not using a key or memory stick. I was using 2 different 2 T hard drives in a dual-bay USB dock. I am going to download the iso again and re-create the rescuezilla boot key. Thanks to everyone for thinking on this challenge.

1 Like

Or the Clonezilla.
It is the engine for Rescuezilla.

Please report your progress here.
I am sure many people are willing to help you.

1 Like

I found the log file that was created on the destination drive. Below is the full error msg. The msg has many references to smart. I'm wondering if Rescuezilla could be incompatible with my system drive (which I am trying to image) which is a 1T M.2 card. I just tried writing the image to a third USB 2T hard disk with exactly the same files being written before the i/o error is declared.
Error creating backup: Traceback (most recent call last):
File "/usr/lib/python3/dist-packages/rescuezilla/", line 131, in do_backup_wrapper
File "/usr/lib/python3/dist-packages/rescuezilla/", line 298, in do_backup
process, flat_command_string, failed_message ="Saving Info-smart.txt", ["smartctl", "--all", self.selected_drive_key], use_c_locale=True, output_filepath=info_smart_filepath, logger=self.logger)
File "/usr/lib/python3/dist-packages/rescuezilla/", line 497, in run
process =, encoding='utf-8', capture_output=True, env=env)
File "/usr/lib/python3.8/", line 489, in run
File "/usr/lib/python3.8/", line 854, in init
File "/usr/lib/python3.8/", line 1702, in _execute_child
OSError: [Errno 5] Input/output error: 'smartctl'

Since I do not have the same drives, I cannot answer to this question.
But I could backup eMMC drive in past with Clonezilla without any issue.
You might want to check out Clonezilla.

I would fsck the disk, just to be sure. But this also could be an .iso error. Redownloading and redoing Rescuezilla may resolve this.

I want to fsck the system drive, but I am inexperienced with fsck. The documentation repeatedly warns against running it on a mounted drive. So I booted from a ZorinOS Live stick. I studied the output of mount | grep '/dev/*' but am unsure if the system drive is being mounted ... probably not, but I need to be certain. When I ran gparted, it displayed the system drive. Am I safe running fsck when from a Live system? Do I just need: fsck or should I use some switches such as not to do repairs?

I may have to use Clonezilla, but I would really like to get the Rescuezilla package running. It includes several utilities that would be very handy in a recovery effort. Of course, I can get those same utilities from the Live install medium. I used to use command-line utilities regularly, but I now much prefer the protection against errors that a gui can provide. Why take chances? I have done some pretty shocking things with cli utilities.

I downloaded Rescuezilla again. This time there was a newer version. Instead of focal, which I download the first time, this time I downloaded hirsute. The results were exactly the same, except that one less utility would run. The same few files were copied followed by an Error 5 i/o error msg. I really need to run fsck, if I knew how to do it safely. See my other note about mounted volumes.

Clonezilla comes with Debian base in addition to Ubuntu base.

stable - 2.7.3-19

This might be more straightforward to your system.