Resolution 1024 x 768 zorin os 17

when i turned my pc on i saw that my 2k resolution has been changed also the refresh rate and when i tried to open settings to change it i couldn't not because i can't open settings but because i literally can't change it ,

i have read the solutions and tried it , , but didn't work

Which solution? What's your specs? What driver do you use? Did you recieve any updates recently, mainly to your driver?


thank you for replaying , i have fixed the issue but there is another problem related to it and other not
93hz is supposed to be 165hz , and there is supposed to be more options for both resolution and refresh rate
Screenshot from 2024-02-07 04-10-03

and the other one is about nvidia
Screenshot from 2024-02-07 04-10-33
i don't think i have to explain this one :sweat_smile:

Can you please launch terminal and run

sudo apt remove --purge '^nvidia-.*'

sudo ubuntu-drivers install

reboot and test:


Screenshot from 2024-02-07 15-19-38

What Nvidia card are you using?

Easiest way to figure out which card and driver in use:

sudo apt install inxi
inxi -Ga

Please post the output.

3060 ti , when i played ( the finals ) couldn't find my nvidia gpu , and now i can't play any game on steam .

Hmmm... I have RTX3060...

Currently, I am using the 545 Nvidia driver.

When you look in Software & Updates > Additional Drivers, what is listed as in use and what options are also listed?

Can you please try the 525 (Proprietary) or 535 (Proprietary). The (Proprietary Tested) versions can be a little bit odd, sometimes.

1 Like

is it okay if i download 550 driver instead of 535
and is the number important or not ?

Yes, I did the same and upgraded to the 545 due to the 535 being buggy and the 525 not practicing proper thermoregulation.

The number is the driver version release number with higher numbers being newer.
For a 3060, you will be able to employ the newest available Nvidia drivers for quite a while.

1 Like

thank you for the info
the download is in progress but i received this error what should i do
here comes another one

Which kernel are you on?

uname -r

After i downloaded 550 and restarted pc i can't connect my pc with ethernet

See if running

sudo systemctl restart networking

gets the internet working again...

Don't get me wrong, installing the Nvidia driver should not disable internet.
It is also odd that a 3060 would fail to comminicate with nvidia-smi using any of the drivers 525, 535, or 550...
Is your nvidia card functioning? Do the fans on it spin?

How did this happen ?

Sorry, try

sudo systemctl restart NetworkManager