Resolution 1024 x 768 zorin os 17

Should i enter 6.5.0-15 generic or recovery mode ?

It looks like you had trouble when installing Nvidia on the 6.5 kernel.
So let's first try the 6.2.0-39 kernel - non-recovery

Once you reach the desktop, check if internet is working.

internet worked but still same graphics card problem

Your graphics are falling back to llvmpipe. I did a net search and both Ubuntu 20.04 and 22.04 users with 3060ti reported that the 515 driver works, but 525 and 535 do not.
Whereas GTX3060 and RTX3060 Nvidia cards do not have this issue.
It's a shame Nvidia is so proprietary given their terrible track record with their own drivers.

You might try the following long list (you can copy and paste each line into terminal):
Reinstall kernel:

sudo apt install --reinstall linux-image-generic

sudo apt install --reinstall linux-headers-generic

Purge Nvidia drivers:

sudo apt remove --purge '^nvidia-.*' && sudo apt remove --purge '^libnvidia-.*'

Remvoe all configuration parameters:

sudo rm /etc/X11/xorg.conf | true

sudo rm /etc/X11/xorg.conf.d/90-nvidia-primary.conf | true

sudo rm /usr/share/X11/xorg.conf.d/10-nvidia.conf | true

sudo rm /usr/share/X11/xorg.conf.d/11-nvidia-prime.conf | true

sudo rm /etc/modprobe.d/nvidia-kms.conf | true

sudo rm /lib/modprobe.d/nvidia-kms.conf | true

Clear cache

sudo apt clean && sudo apt autoremove

Install nvidia drivers:

sudo apt install nvidia-driver-515

sudo apt update && sudo apt upgrade

Reboot and test...

1 Like

After i write all the codes here is the pictures , it is weird i have the E : massage after every code i type






The same


When i entered to the additional drivers here is what i found

An error is a stopping point. If you have an error, the command has failed.
Each following command should only be run if there were no errors.

Let's start at

sudo apt --fix-broken install

and relay the terminal output.



Another error...after i ran sudo apt --fix-broken install

I cannot see the full output.
I do see a line saying that there is no room left on the drive. Is your hard drive full?
That would explain all the issues...


i can cut from the tib and give some space to /boot but idk how

The screenshot of your drive shows that /boot is almost completely filled.

You can clean out some space by removing old kernels.
You can *check what is there with

ls -l /boot

I do think your boot partition should be larger. However, in order to enlarge it, it needs available space adjacent to it. You currently have it surrounded by other formatted partitions. It can be done... By moving partitions around,. it would be a bit of leg work of logging into your NTFS drive with Windows and your Zorin Drive... Really might be easier to just reinstall Zorin OS and size the partitions during the install to allow plenty of room.

i wish if i can reinstall it and everything but i did something wrong in zorin gparted and tried to free some space for /boot , ended up deleting windows by mistake because when i switched to windows after restarting i saw some kind of repairing screen and i knew i did something wrong , anyways i can reinstall it if there is a way to keep my 150gb videos .

You can back up your videos on an external drive or large volume cloud drive.

i don't have flash that big and there is no free cloud drive can handle this ( trust me i searched ) is there anyway i can fix the error issue ?

It is bedtime for me here (It is after 11pm my time) but I will tag @337harvey as one of the members very good with partitions. He also wrote a partitioning guide on the forum.

If Windows OS is shot, you may be awilling and able to just reformat that space and slide your GnuLinux partitions into it, then use newly created space at the end of the drive if you want to install Windows OS on that.

You will need to be sure you protect, back up or salvage any files from the NTFS partition first.

1 Like

Good night .

This will work for Zorin 17 as well as 16. It's a detailed installation guide that defines how to partition for Zorin (or any OS for that matter).

Partitioning Demistified will give you more details about how to move things around.

Read both before proceeding (partition part of the install guide, then the demystified guide). Ask questions if you don't understand something, I'm more than willing to help.

Take your time and be certain of your decisions. It's not something you want to continually change.

1 Like

Screenshot from 2024-02-08 13-19-17


thanks to allah my problem has been solved , the resolution the refresh rate and nvidia problem and then thank you guys , i don't know how but i turned my pc on after like 6h and everything is some how working again thank you all for the help and sorry disturbing
:heart:

Yeah its more than likely driver. Just sudo line it or use a gui software. Free tutorials are all but gatekeeped lol

You probably just needed a reboot for the modules to be loaded. :wink: