Root has Low Disk Space

Low disk space File system root have 1.1GB
How do I fix this problem? It won't even let me install updates. I was using Zorin 16 Lite and lost Taskbar. I loaded 16.1 and have taskbar but is on Gnome. How can I fix low disk space problem?

What size partition is Root occupying?
In this case, Root refers primarily to your Install Of Zorin OS Lite.

You can check if error logs have been growing and bloating. These are located in /var/logs

You can run in terminal

sudo apt clean && sudo apt autoremove

In the Zorin utility Disk Usage Analyzer, you can look to see what the space hog is. It can take the Disk Usage Analyzer sometime to run... Launch the app, select the drive, then you will see the spinning "Process Working" icon. Grab a sandwich or something...
Once it is complete, you should have a tree in the left pane that allows you to narrow down where all the big file space is.

I am now down to ~763 MB free space.
Size of Root partition how can I find out?

I ran sudo apt clean && sudo apt autoremove
I ran the Zorin "Disk Usage Analyzer" Took less than a minuet to open. I have a split screen display on Left is a Tree look with 1st folder Full looking Red rectangle box with / as it name.

/ box looks 98% full Size 35.6 GB, Contents 467067, & Modified Today.

USR box looks 10% full Size 10.3 GB, Contents 249154, & Modified 3 months.

VAR box looks 60% full Size 24.6 GB, Contents 215079, & Modified today.

LIB box looks 90% full Size 22.4 GB, Contents 213503, & Modified today.

LOG box looks 5% full Size 2.0 GB, Contents 318, & Modified today.

There are many other box that are in MB & KB size.

All this shows me is, running out of partition space. I have several Samsung #840 drives and I think the one that MS Windows and Zorin 16 is on is a 1 TB. The total drive space in this computer is little over 4 TB.

This may be of use.

It's Foss Clean Up A Disk

As with any command, think and proceed with caution and understanding.

You have build up a lot of logs in /var/log directory... You can clean out the logs if you want.

These are essential system files.
Your root is certainly not stored on 1 or 4 terabytes...
Can you use Disks app to relay the Size of your Zorin ext4 Partition?


I am back on xfce, I fixed the taskbar. I thought the logs were that way so I got rid of them thinking all kb will help. I also discovered Zorin Appearance was wrong so selected the proper one and was able to reinstall taskbar icons. If I am reading this correctly
If you notice on the above DISK image I have 1 free space 105 GB and another free space of 178 GB. How can we add that GB where it is needed?

How do I send these two images

None of the images are showing.
You can upload an image to the forum by clicking on the Image Icon on the post toolbar:

Navigate to the location of the image and select it.

I may almost have it.

Looking at this, I think a lot of the confusion comes down to having so many directories mounted to /media.

Does that mean I am real close to a crash and burn. What should I do?

Ummm I gotta say... I have no idea what is going on with all of your media mounts there.
Even your Zorin Partition shows it as Mounted at /media...

You also have 275gigs or so of free space sitting unused.
Your root directory shows that it is less than half filled. So it is not really in danger... But Root directory is where Media Mounts and since /media adds up the way it does, it makes the system think your / dir is overflowing, even if it isn't.

What is partition3? It is only 40gigs.
And your Swap partition is rather large... If using Hibernate, you need a swap partition, but it never needs to be more than double your physical RAM.

You've mounted your root partition to /media, therefore it can not access the available space on your root partition you have made. You need to mount your root to it's actual partition you created.

Your root partition should have been mounted to root, I'm not understanding why you have so many partitions mounted to your /media nor why when initially installed your root partition was changed to media.

Where you mount your partition is the drive in which it will write, regardless of how much space you gave the initial partition.

You should have made 3 partitions if using swap. Swap, Home, Root... that's it. The system would have asked you if you didn't already have one for the boot. Like @Aravisian pointed out as well, your swap is entirely large.

I can see creating the additional partition for backups, but I don't understand the point of creating a new partition for each folder than dumping them all into the same media partition. All your folders should have been dumped into your /home partition. If you're going to create a backup partition it can't be mounted to the same mount point has everything else. If you bork your system, then your backup will be inaccessible because you mounted it to the system itself.

My home partition that I created is mounted to home, swap to swap, root to root. They only write to the partitions that they are mounted on. If there is ever an issue with my system, I can easily reinstall and be back in the time it takes for the distro to actually install. with all my files right there. I only have to select my theme and icons, then I'm done. You wouldn't be able to do such with your current configuration.

What is the purpose of all those free space partitions?

Your first step should be cleaning up your partitions and mounting them correctly. Your next problem will be determining how many root files were written to the wrong directory and now you may have to repair or reinstall your system. Then you'll have to remove the root files that were written to the wrong partition.

How this got this way I don't know. In the beginning I had a dual boot in MS Windows. Then I stumbled into Zorin it being the 4th or 5th try with Linux. I had Zorin on a USB drive while trying it out. At some point I removed Windows 7 was still on hard drives. Finally SSD price started coming down and they were small if you recall. Also in this mess we lost some WDC and replaced with SSD as price came down and size increased until you see what I have now.
Some period of time I bought Zorin 16 PRO and set it up with 3 partitions as @Aravisian said on Gnome. Next installed the xfce and it worked much better. So you take the above scenario and me pushing 85 that knows nothing about Linux or just enough to be dangerous and have forgot a lot about MS Windows you end up with what you see. I don't have a clue about the free space unless it is results of removing old programs.

I understand what my first step should be but don't have a clue how to get started anymore. So if you guys will hold my hand with simple detail procedures I can still follow instructions. I thank you guys very much for all the help.

1 Like

Well first question is: How would you feel about reinstalling Zorin OS and setting everything up logically (With your personal files backed up)?

1 Like

Yes! I have spent most of today and yesterday trying to get my head around this problem and now have a bunch of questions to get answered.
First, my computer I built it and have Drive 0, Drive 1, Drive 2, and Drive 3 at the moment is not installed, its a SSD 250 GB. Drives 1 & 2 are HHD others are SSD.

Drive 0 Basic, GPT 250 GB NTFS Windows 10 111GB free space. So C:, E:, F:, G:, H: are all used with Windows 10.
The rest of the space on Drive 0 is for Zorin 16 Pro following instructions for Dual Booting with Windows 10. Next started having problems with Canon printer MB2720 and Gnome and I followed your instructions installing XFCE and everything was OK again.
I don't know why /media is involved, I don't remember anything dealing with /media. Don't remember anything about the Why on free space unless if more space was needed in Windows10 I had some. On partition 3 it say's it is Partition Type Microsoft Windows Recovery Environment.

2nd Question If after installing Zorin 16 Pro gnome and then installing Lite how many Ext4 and / should I have? Why is partition 1 so small, what is EFI system? Partition 2 Basic Data Windows 10 and not mounted. Partition 3 is Microsoft Windows Recovery Environment and Not Mounted, what is this for? Partition 4 is Microsoft Windows Recovery Environment andSwap (version 1) -- Active? Partition 5 is Basic Data Ext4 (version 1) --- Not Mounted? Partition 6 type is Linux Filesystem Ext4 (Version 1)--- Mounted at Filesystem Root. @DeanG Did he know about Dual Booting I would think some of this had to do with dual boot.
Can you show me a Tree layout how it should have been installed.
Hope this will help.

Your copy of Zorin OS Pro includes Zorin OS Pro Lite. So, if you performa reinstallation of the O.S., you may want to skip a step and just install Pro Lite.

This is the Bootloader partition - So please leave it UnChanged.

This is a partition created by default by the supplier. It contains a backup copy of Windows OS for recovery of the OS. It's like a Rescuezilla of Windows.

Your copy of Zorin OS Pro includes Zorin OS Pro Lite. So, if you performa reinstallation of the O.S., you may want to skip a step and just install Pro Lite.

I don't understand what you mean or what this will do. Do you mean just reinstallation of Zorin 16 Lite? Can this be done without messing with Window 10?
Give Windows 10 a early retirement. I only used it to install Windows 10 updates.

Then Clone Zorin to Drive 3 SSD 250 GB after Temporary installing Zorin Lite. Have got to be able to run business so not under any rush or Drive 0 is taking longer than thought.

Next Clean Drive 0 and as you say "reinstalling Zorin OS and setting everything up logically (With your personal files backed up)?" Drive 0 would have 1 TB to set it up however you like.
Take Drive I (2 TB HHD use for Backup) clean it up and use for Zorin Backup.

Ok, it looks like your installer is a little sqirley... did you do the alongside windows option?

This can be cleared up, but we have to take a look at something. Open the terminal and type sudo gedit /etc/fstab. This will open the file system table that mounts and loads the partitions your OS uses. The first entry at the top should be for root and mounted on /... it will look similar to this:
/dev/root / ext4 defaults 0 0

This is important. If it has anything after the / delete it (check the other entries to make sure none of them are using / alone.

Save, close, reboot.

Back in disks, partition 1, 6 and 4 are bootable (star). 6, i believe is your root partition... you will have to confirm.

Partition 6 can use the free space to the right of it. Highlight (click) partition 6 and hit the cog at the bottom left of the partition area, choose resize. In the box, after, decrease the size to increase partition 6. The other free space can be applied also, but much shifting would be required. I can provide a Walkthrough, but it will be time consuming and require focus as to not mess things up.

Hit the check mark in the upper left of the window to apply the changes, and close disks (a reboot is recommended).

There is a tutorial on how to partition and install zorin 16 (uses the something else method).

Here is what I got.

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/sda6 during installation

UUID=a87bccd1-0337-40d0-be7d-6e585356b85a / ext4 errors=remount-ro 0 1

/boot/efi was on /dev/sda1 during installation

UUID=08FF-362A /boot/efi vfat umask=0077 0 1

swap was on /dev/sda4 during installation

UUID=0a5a1f70-ee34-4562-abac-39a29907144f none swap sw 0 0
/dev/disk/by-id/usb-Samsung_Flash_Drive_0305521040011184-0:0 /mnt/usb-Samsung_Flash_Drive_0305521040011184-0:0 auto nosuid,nodev,nofail,x-gvfs-show 0 0

I pasted the results of "sudo gedit /etc/fstab" would you look at it see if it is OK to proceed to next step. Is the Top you refer to at #9 if so what does this mean "errors=remount -ro 0 1"