Rotate touchscreen panel 90 degrees right

Hi Please can someone who knows linux commandline much better than me help me out

how do i set the touch pad to rotate through 90 degrees

if i open the terminal and"input -list" i get the following
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ SINO WEALTH USB Composite Device Mouse id=8 [slave pointer (2)]
⎜ ↳ Goodix Capacitive TouchScreen id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Video Bus id=6 [slave keyboard (3)]
↳ SINO WEALTH USB Composite Device id=7 [slave keyboard (3)]
↳ SINO WEALTH USB Composite Device System Control id=9 [slave keyboard (3)]
↳ SINO WEALTH USB Composite Device Consumer Control id=10 [slave keyboard (3)]
↳ SINO WEALTH USB Composite Device Wireless Radio Control id=11 [slave keyboard (3)]
↳ bytcr-rt5640 Headset id=12 [slave keyboard (3)]
↳ axp20x-pek id=14 [slave keyboard (3)]
↳ gpio-keys id=15 [slave keyboard (3)]
↳ gpio-keys id=16 [slave keyboard (3)]
↳ Goodix Capacitive TouchScreen id=17 [slave keyboard (3)]
but when i try and use the following to rotate it xinput set-prop '<device name>' 'Coordinate Transformation Matrix' <matrix-elements-rowwise>
`xinput set-prop ‘Goodix Capacitive TouchScreen’ ‘Coordinate Transformation Matrix’ 0 1 0 -1 0 1 0 0 1

i get "Warning: There are multiple devices matching ‘Goodix Capacitive TouchScreen’.
To ensure the correct one is selected, please use the device ID, or prefix the
device name with ‘pointer:’ or ‘keyboard:’ as appropriate.

unable to find device Goodix Capacitive TouchScreen" and dont know how to correct it

@ndg_2000 Hi and welcome to the Forum.
There are previous threads on here regarding screen rotation which may (or may not) help you.


1 Like

Hi zabadabadoo

thanks for offering those treads but unfortunately they don’t help. I have managed to rotate the display so it is landscape using display settings but unfortunately the touch screen element is now 90 Deg out compared to the display after rotating. Hence my post. In Ubuntu it was just a case of using the set-prop but this time there are 2 devices named the same and I can’t do it from the command line. I’m a total noob at Linux and Google has not been helpful this time

Nigel

Well after an hour of brute force editing of the line I finally got it to work

I should have been typing
`xinput set-prop 13 ‘Coordinate Transformation Matrix’ 0 1 0 -1 0 1 0 0 1

Simple as that

Now I have the command how do I automate it on startup as I’m opening the terminal on startup every time at the moment.

I have tried adding @restart and the above to crontab but it didn’t work.

2 Likes

So you are fixed 50%.
I have not added script or commands to run at startup myself. I just did a search for same and found this which may be of interest. Maybe the answer with 38 votes.
Otherwise you will have to wait for a Linux non-noob to help you.