RTL8111/8168/8411 wired network controller internet connection drop Zorin OS 15.3 Core

Good day, my internet connection regularly drops out in Zorin OS 15.3 Core.
When I look in the taskbar, there is a question mark in the icon of the internet connection.
If I then switch off this connection and switch it on again in Zorin, I will have internet again.
This is about a wired internet connection

Do you know the network controller of your machine? Make, model?
Otherwise, please type sudo lshw in your terminal (ctrl+alt+t) and paste, in your response post, any result appearing under " *-network" header. Fyi, there may be multiple places this header shows up in that output.

Dear Carmar,
Here you can see the output from sudo lshw:
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: enp3s0
version: 06
serial: 94:de:80:c0:1f:b8
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip=192.168.0.135 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
resources: irq:18 ioport:d000(size=256) memory:d3904000-d3904fff memory:d3900000-d3903fff

*-network
description: Wireless interface
product: AR922X Wireless Network Adapter
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:05:00.0
logical name: wlp5s0
version: 01
serial: 64:66:b3:ba:d7:98
width: 32 bits
clock: 66MHz
capabilities: pm bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=ath9k driverversion=5.4.0-52-generic firmware=N/A ip=192.168.0.237 latency=168 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:19 memory:d3800000-d380ffff

Please install the package shown in the screenshot below:


Using Synaptic. If you still get the drops, reboot and see if that helps (after installing that package). Then let us know if that worked or not.

1 Like

Thanks for your help. I installed r8168-dkms via synaptic.
Now I’ve restarted my computer (I always do this after installing software out of habit) and haven’t had any interruptions yet.
I will report it here as soon as I have a break again.

the internet has just gone down again.
i have had to reconnect it.

**** I forgot step 3 should have been to update first. Just edited that in. Sorry. *******

In Synaptic, for r8168 package, Mark for Complete Removal. Close Synaptic.

Follow steps here: https://tuxbyte.com/how-to-get-your-realtek-rtl8111rtl8168-working-updated-guide/
Specifically, only the Ubuntu lines.
So, Step 1: sudo nano /etc/apt/sources.list and edit in terminal.
OR
sudo nautilus, browse to /etc/apt/ and open sources.list with whatever editor. BE CAREFUL not to delete any files while using nautilus with sudo permissions.
Step 2: and add for each line starting with “deb”, the following, "non-free’ or “universe” at the end (all without quotes). There are examples on that page.
Step 3: sudo apt-get update
Step 4: sudo apt-get install r8168-dkms

Hi dear Carmar,
i modified the sources.list but only the lines starting with deb
not the lines starting with #deb
is that good?

# deb cdrom:[Zorin-OS 15 Core 64 bit]/ bionic main restricted 

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://archive.ubuntu.com/ubuntu bionic main restricted universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu bionic universe universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic universe
deb http://archive.ubuntu.com/ubuntu bionic-updates universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://archive.ubuntu.com/ubuntu bionic multiverse universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse universe
# deb-src http://be.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://archive.ubuntu.com/ubuntu bionic-security main restricted universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://archive.ubuntu.com/ubuntu bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://archive.ubuntu.com/ubuntu bionic-security multiverse universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse
deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main universe
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main
# deb-src https://deb.etcher.io stable etcher

Yes, you did the right thing. The hashes are comment markers. I’m hoping this method provides a newer version of r8168 (current one listed is 8.045.08). After Step 3, you can close the terminal and open Synaptic. Search for r8168 - if 8.045.08 is still the only version, then we may as well skip Step 4 (same as installing on Synaptic) and look for an alternate solution. Will await the results.

Hi dear Carmar,
this is the terminal output:
hendrik@Home-computer1:~$ dkms status
nvidia, 450.80.02, 4.15.0-121-generic, x86_64: installed
nvidia, 450.80.02, 4.15.0-122-generic, x86_64: installed
nvidia, 450.80.02, 5.4.0-51-generic, x86_64: installed
nvidia, 450.80.02, 5.4.0-52-generic, x86_64: installed
r8168, 8.045.08, 5.4.0-52-generic, x86_64: installed

so the latest driver is installed, but the internet was just disconnected again.
i had to reconnect it through software.
I’m starting to think that the connection is being broken by other processes such as gnome extensions … that’s just a thought hey

According to some folks, there is a temporary workaround: see #4 and #5 here.

Proceeding with implementing the above temporary workaround, I’d like to first remove the changes from our prior attempt.
Please close terminal and open Synaptic and confirm that the r8168 is installed, as before, and that it is green (no broken package). You should also return your sources.list to its original form (remove the “universe” at the end of those lines that you added).

Now moving to the archlinux thread suggestion. Please follow the first few instructions here to get to the grub editor. On Aravisian’s instructions, do not make any change to quiet splash as he suggests. Instead, after quiet splash you will add noapic
Then close as he recommends (ctrl+x) and continue to boot.

The above will do a one-time boot change to see if the archlinux workaround actually fixes the problem. So, once you change this, do not shutdown/reboot, and put load on your network controller (for example, watch Youtube which has a high transfer rate) to see if it holds the internet connection. If it works we can do a permanent grub edit.

Hi dear Carmar,
I got the source.list back to what it was like before changing it.
Then I added noapic to the grub when starting Zorin OS.
But the problem continues to arise.
I have the online radio on and watched videos and on the second screen started Facebook.
I keep thinking that processes that connect to the internet are causing problems. I’m not sure.
On the other side I wonder whether the Wi-Fi card can cause interruptions to the onboard Ethernet card

I don’t think the wi-fi card should cause interruptions - at least I would think the manufacturers account for that but then again your guess is as good as mine. You could try using the wireless - I stopped using my wired connections a while back and have not noticed any difference in speed. I know that doesn’t address the problem but thought I’d mention it.

Finally, there is this: https://bbs.archlinux.org/viewtopic.php?id=195251
But the poster doesn’t seem to recall exactly what they did so I’m wary of recommending those changes.

Hi dear Carmar, thank you very much for the help offered.
As for the last link, I went there to take a look, but I will not venture to manually change the settings.
I have internet, sometimes for hours on end and sometimes it drops.
What you say there to avoid wired internet and only use wifi is not such a bad idea.
Thank you.