Scan Failed, Cannot Connect to Scanner Brother MFC-J497dw all in one

Good day, I have a friend via email who cannot scan with his Brother all-in-one scanner/printer in Zorin OS 16 Core.
Previously on Zorin OS 15 Core it could print and scan.
We have closely followed the instructions on the Brother website with the Brother Install Tool to install all the drivers.
The printer is connected via USB and Mike can print but not scan.
When Mike wants to scan, the Brother scanner is discovered but cannot connect.
These are the specifications of his computer:

  Kernel: 5.11.0-41-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-41-generic 
  root=UUID=0f27e13a-9cfb-4c81-ba98-0f1cb8a48cc4 ro quiet splash 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 
  Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal 
  Type: Desktop System: HP product: HP Pavilion All-in-One 24-r0xx v: N/A 
  serial: <filter> Chassis: type: 13 serial: <filter> 
  Mobo: HP model: 838B v: 0100 serial: <filter> UEFI: AMI v: F.20 
  date: 12/11/2018 
  Topology: Quad Core model: Intel Core i7-7700T bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
  bogomips: 46398 
  Speed: 800 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
  Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5912 
  Display: x11 server: X.Org 1.20.11 driver: i915 compositor: gnome-shell 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel 200 Series PCH HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a2f0 
  Sound Server: ALSA v: k5.11.0-41-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A port: c000 
  bus ID: 03:00.0 chip ID: 10ec:b822 
  IF: wlp3s0 state: down mac: <filter> 
  Local Storage: total: 1.15 TiB used: 17.43 GiB (1.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Samsung model: MZNLN128HAHQ-000H1 size: 119.24 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 3H3Q scheme: GPT 
  ID-2: /dev/sdb vendor: Toshiba model: DT01ACA100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: A800 scheme: GPT 
  ID-3: /dev/sdc type: USB model: USB3.0 high speed size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 2210 
  scheme: GPT 
  ID-4: /dev/sdd type: USB model: USB DISK 2.0 size: 14.45 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / raw size: 93.13 GiB size: 91.17 GiB (97.89%) 
  used: 12.52 GiB (13.7%) fs: ext4 dev: /dev/sdc2 
  ID-2: swap-1 size: 14.90 GiB used: 0 KiB (0.0%) fs: swap 
  swappiness: 60 (default) cache pressure: 100 (default) dev: /dev/sdc1 
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: amdgpu temp: 44 C 
  Fan Speeds (RPM): N/A 
  Processes: 284 Uptime: 1h 28m Memory: 7.62 GiB used: 1.91 GiB (25.0%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 

The Brother printer scanner all-in-one is MFC-J497dw
We then removed everything from Brother on the PC and downloaded the separate drivers and install them with the Gdebi program, but alas.
Mike can print but not scan

Please try


sudo dpkg -i brscan4-0.4.9-1.amd64.deb


sudo dpkg -i brother-udev-rule-type1-1.0.2-0.all.deb

Reboot and check again :grinning:

Thanks very much Michel, will give Mike these commands and let you know if that worked.

1 Like

I fixed the first link, i wrote wget wget instead of wget. Doing things on a smartphone is not always a great thing :sweat_smile:


Hi Michel,
it didn't help, Mike still can't scan.
meanwhile Mike also tried with xsane and that also gave a negative error: "Could not find device, brother4:bus2,dev7, Error argument"

Beginning here:

Might be a helpful read...

Some have luck by running the printer on Wifi instead of the printer cable. :expressionless:

We already have used this driver tool installer

Hello Zorinhendrik, scanning the brother dot com site I found this, don't know if it will help, but they mention something about a Scan-key-tool.

The model is listed in the Related section.

But it's strange that it worked in 15.3 and now does not. Can he recall how it installed it on 15.3, was it also with the help of this tool?

Hi dasjdoom,

thanks for the commands but it didn't work either.
with Zorin OS 15 Core was no problem, just install and go.

Throwing this out there: I cannot print or scan via USB on Debian 11 or later, Ubuntu 20.04 or later and on their derivatives (Linux) | Brother

Maybe you could try downgrading the kernel to 5.4 or 5.8 ?

1 Like

We have already tried that, but with no positive result.

Oh dear Michel, we really don't want to do this.
Mike has a dual boot system and at the moment he switches to Windows to scan.
But we are looking for a solution that he doesn't have to do this anymore.

That is why i suggested to downgrade the kernel. You said it worked on zorin 15 which if i am not wrong is using kernel 5.4-5.8, if you try that kernel in zorin 16 it might work.

sudo apt install linux-headers-5.4.0-91-generic linux-modules-5.4.0-91-generic linux-modules-extra-5.4.0-91-generic linux-image-5.4.0-91-generic

Reboot and make sure your booting with that kernel using grub

FYI. Latest kernel I have on Z15.3 Core is 5.4.0-91

1 Like

I copied it from another threat, will change it.


I have had similar issues with my Canon TS8100 the solution? VueScan from
This is a paid for product and I appreciate would rather not have to pay for software but it is a great product (a Windows user was able to scan to a 30 year old Epson scanner in Windows 10 according to one of the testimonials).

Am now using Devuan 4 and ironically I can now use XSane. If push comes to shove, try Devuan 4.

And another throw in:

1 Like

Dear people, thank you very much for thinking along about possible solutions.
We are only of the opinion that the drivers have been installed correctly.
Printing is going great.
The scanner, on the other hand, is found but does not scan.
The only problem here is that the USB connection does not work despite the software drivers being installed properly.
We are looking for a solution that restores the connection with the USB cable.

If he is having trouble with USB, he could try networked connections. If using networked, it could be a firewall problem - try turning try that off.

1 Like

There is mention of a patch here: