Screen Blanking Persists Through Settings Changes

I'm having an issue where the screen continues to blank after about 30 seconds of zero user interaction. This is despite all attempts to change the setting via normal means. This does not happen while I am actively using the machine.

Request: I'm looking for help to either find out what's going on [OR] to return to default/normal whichever system setting I've not been able to find.

Background: I believe this is related to my install of the Caffeine extension. When I noticed this problem, I tried disabling the extension as well as modifying the settings of that extension with no success.

I've tried the following without success:

  1. Blanking setting in the Settings application - no joy.
  2. Change screen blanking timeout
    (I don't know if this is even the best way to address screen blanking because the way I read the method outlined in that tutorial, means that we're setting time delay for the system to transition to an idle state; not necessarily the delay before the screen blanks.)
  3. gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing as outlined in this AskUbuntu post.
  4. Dconf editor - no changes made to any setting involving screen and/or blanking took effect. The same as setting the blanking settings in the control-center/settings application, as well as those found for the Caffeine extension.
1 Like

Have you tried:
gsettings set org.gnome.desktop.session idle-delay 0

This is directly reflected in Zorin menu > Settings > Power > Blank Screen. If you change it to a number (in seconds) that's not already in that list, it'll update with the number you input. Setting it to zero means 'never blank'.

I've got that setting set to 0, and I created a keyboard shortcut in Settings > Keyboard Shortcuts:
Screen off ( Super + L )

gnome-terminal -- /bin/sh -c 'xset -display $DISPLAY dpms force off > /dev/null 2>&1'

Yes, I've tried that and with different time settings as described in your last post which I linked above in #2. Unfortunately, it still does not change anything and the screen continues to blank after a very short delay.

I should also mention that after making any of these changes, I also restart the shell with a command. This also persists through reboots.

Is this machine a laptop, and is it plugged in when this happens? Some laptops have BIOS / UEFI settings that blank the screen when the machine is on battery... you might check there.

Also check Settings > Privacy > Screen Lock, be sure everything there is set so the screen doesn't blank or lock.

1 Like

It is a laptop and is plugged in when making these changes.

The only BIOS-level battery settings my machine has is an "Adaptive Battery Optimizer" setting which doesn't affect blanking times. I believe it also has a "Battery Percent" toggle, but I can't remember.

I don't think this is a BIOS-level setting, primarily due to the fact that these settings have remained unchanged from before upgrading to ZOS16. The blanking also worked properly right after install of ZOS17 - and I believe the only changes I made to the system since installing ZOS17 which affect the screen/blanking: is installing Caffeine, so that's why I mentioned that in the first post.

Have you uninstalled and purged Caffeine?

sudo apt purge caffeine gnome-shell-extension-caffeine

Perhaps just uninstalling rather than purging didn't remove some of the Caffeine files.

That did seem to work. Thanks.

Rather than running the command in terminal, I looked in Synaptic just to make sure I got everything Caffeine-related.

It's just unfortunate that I had to purge the app from my system to return it to normal - I wanted to keep it installed to use it when needed, but it seems that the enabled state can't transition to disabled state in any circumstance.

I have the same situation. Just installed Zorin 0S 17 and if I'm not actively using the keyboard the screen blanks. In 16 after the set time the screen would nicely dim and then blank.

Don't know what Caffeine so I'm sure I didn't install it. :grinning:

Tried the command above just in case but it did nothing since caffeine wasn't installed.

Set a stop watch to see how long it took until blanking... exactly 30 seconds.

1 Like

hmm... updated the software and had to reboot... and now it is not blanking... wish I could give better understanding.