Screen Flicker on Zorin OS with AMD graphics

I also have the same screen flicker. I have a HP Laptop with AMD graphics. If it helps at all I can post the model number later. I was trying to troubleshoot.

Currently I'm loving Zorin. I've tried out LinuxFX,Ubuntu Mate,and BionicPup before but do to some confusion defaulted back to Windows. But I legit love Zorin and my Linux understanding over the past few days has grown exponentially.

You may have some luck using the third party AMD graphics drivers:

sudo add-apt-repository ppa:oibaf/graphics-drivers

If it successfully is added with no errors (404 error), then run

sudo apt update && sudo apt full-upgrade

Screenshot from 2021-09-17 06-44-09

I did the steps for upgrading on the other thread, it doesn't flicker all the time, but it still does it.

The screenshot you posted shows that the repository was not added and therefore, nothing was upgraded.
I'm not sure why, either... Here is the repository

And as you can see, it is:

sudo add-apt-repository ppa:oibaf/graphics-drivers

No one else has shown it to fail, either. I am confused...

So it was two entries, not a whole line typed out?

I'm at work right now but I'll try it again when I get home and update.

Sorry I'm a complete Linux noob lol

1 Like

Don't worry, so am I.

We got the the power.

I forgot the s on graphics. I got it downloaded and upgraded.

Still getting the flicker. It feels like my backlight for the display is whats flickering, or just the brightness is flicking dim and bright.

I tried the panel self refresh adjustment from another chat thread, didnt work either.

I did a search on this issue, since I am not sure on this, either.
I found this:

One of the suggestions is a Temporary Fix... I think it would be worthwhile for you to test that. If it works, then that will establish that it is the graphics or drivers, not the hardware.

I installed Zorin 16 Lite on my Lenovo Ideapad today. Screen flicker comes and goes. My screen flickers about 3 times/sec when it happens. I ran the commands from here, but that did not fix it. I have an AMD Stoney GPU.

Have you tried the kernel parameter iommu=off?

sudo nano /etc/default/grub

Change "quiet splash" to "quiet splash iommu=off"
ctrl+x to exit, then y then enter.

The file that opened had this:

I added " iommu=off" at the end.

I exited the editor.

The screen continued flashing for a few minutes but has now stopped.

Flicker is back.

Searching this:

It supposedly was fixed by kernel 5.3 / 5.4 - Zorin OS is currently using 5.11.
Not sure if it regressed or if the fix from the previous kernel did not work.

You may try the "tearfree" tip outlined here:

1 Like

I applied the patch. We'll see how it goes.

The "patch" helped. Hardly any flickering now. Thanks.


Too bad it is not a fix, though.
I can't decide which I love more... Nvidia which just outright says "no" to open source or AMD which pretends to support Open source while simultaneously utterly ignoring it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.