Screen kept flickers when running Zorin OS 15 Lite for the first time (same with USB boot) (1) Literally,I just installed the Zorin OS 15 Lite on my laptop with Windows 10 at it's own partition,and it just flickers and not gonna stop it.

Brand: Acer
Model: Aspire 4530
CPU: AMD Turion X2 RM-74 2.2ghz dual-core processor
Graphics: NVIDIA GeForce 9100m g
HDD storage (in partition): 64GB (250GB in total of storage capacity)

Hi and welcome to the forum. I see you have Nvidia graphics and using Z15 Lite.

Have you checked for "Additional Drivers" in Software Updater?

Others on here with Nvidia graphics experience may be of more help than me. I do not to have Nvidia graphics.
I have done a websearch and found this item which could be of use, otherwise hang on for other helpers.

1 Like

From Zabas link - the first reply /suggestion to ubuntu-drivers autoinstall is a good one, but I would suggest as a follow up that the Nvidia-430 would be a better choice currently to the one offered in that thread (Nvidia-390).

Additionally, you might check your screen refresh rate:

I've tried it already,but it just glitches the whole system and crashes. (forces to restart)

This is the reason that I used the open source ones,instead of NVIDIA's.

Which shall I choose, a 390 or 430?

Because the graphics card was manufactured from 2008,and it's been over 12 years already.

I would still try the 430 in order to have it jive with the later kernel and current software. If that does not work out, you can try the 390.

I was afraid that it will crashed he whole graphics and glitches the display.

Ctrl alt f1 didn't works when it glitches,and ctrl alt del too,but the mouse pointer still movable without a integrated trackpad .

What if you run the kernel parameter nomodeset and run nvidia-setings as root to toggle the nivida card on and off?

And there goes nothing...
The graphics glitches and it just breaks for no reason.

Sorry I can't capture the video of it in action because my phone got power failure by accident,and I lost the footage of it glitches

(Update: I fixed that already)

This is what it looks like,it stopped working and started to glitches.

Wow... I feel your pain seeing that.
Can you post the output of

sudo nano /var/log/kern.log

or it may be

sudo nano /var/log/kernel.log

as well as

sudo nano /var/log/syslog

Can you paste the output of

inxi -G

(If you need, you can install inxi with sudo apt install inxi)

I'm currently having trouble sending images now,just give me a moment.

2021-05-15 20.59.12

Also I tried to use inxi -G command

And here's the result

Have you tried a live of Z16 beta and see if the error appear there too?

I don't think I have time to try it,but I'm interested to try out the Z16.

Ok, system log is empty. For kern.log, you may need to open it in GUI with a Text Editor and paste the contents here.
Your inxi -G output is a bit sparse. Not sure why - though it may be an Nvidia thing...
Does your computer have integrated AMD graphics as well as the Nvidia Graphics card?

According to inxi, the Nvidia Proprietary driver (Either 390 or 430) is not being used and it is still using Nouveau.
Are you able to boot into the GUI desktop?
If not, are you able to if you hit the e at the boot menu and add the kernel parameter "nomodeset"?
You can do this at boot by choosing "Boot with safe graphics" or by the following;

Literally this laptop has a integrated stock Nvidia graphics

Also,I don't know where to put the "nomodeset". Because I'm a new Linux user and actually trying to try out the operating system itself.

(Update: I found that info about where to put the "nomodeset" at)

Not the best first impression, is it?
The link I posted above gives step by step by step instructions on how to add nomodeset.
Here is another guide that has pictures that show it more clearly.

I would like to know more about this...

Here's the information about this gpu: