Screen tearing and now "locked out" from attempting to troubleshoot

Hello Hello!

Summary: I added Option "AccelMethod" "uxa" to a config file to solve the horizontal screen tearing problem and got locked out of my laptop. I get taken back to the login screen every time I log in. Have to get back in and fix the tearing.

Story Below

Where it started: So as you can read from the title, I have screen tearing. I got a new Framework laptop and didn't have the screen tearing problem out of the box. I believe it was after I changed the fractional scaling. Changing it back doesn't fix the problem.

What I've done: As any Linux user, I attempted to troubleshoot. I picked up a lead on enabling TearFree through a config file. I followed the steps on this video and this guide; though I used sudo nano instead of sudo touch. I also used Driver "intel" because Driver "i915" did nothing. It actually made the problem many times worse with what I had before plus new ones. This is what my screen looked like after turning my laptop on multiple times:

I also switched between Driver "intel" and Driver "i915" and still the same problems.

Getting to the problem: Since the previous guide and video tutorial didn't work, I came to the Zorin forum. Didn't find much, but this guide someone linked to. It said to add Option "AccelMethod" "uxa" if Option "TearFree" "true" did not work... so I did. Restarted my laptop and logged in. Got taken to a black screen for two seconds and back to the login screen. Now I'm basically stuck. I've tried logging in and turning it off and on multiple times with no changes.

Have timeshift in there
Kernel driver in use: i915
Bios Version: 03.07 (up-to-date)
Operating System: Zorin OS 16 (should be latest stable version)
Core: Intel i5-1135G7
GPU: Intel Xe Integrated GPU (I think)

You can reboot then tap the esc or tab key after you see the motherboard splash screen.
This will show the Grub Menu.
Select Advanced Options for Zorin
Select Recovery...
In the Recovery Menu, arrow key down to Drop to Prompt
Hit enter
You can either

sudo rm /etc/X11/xorg.conf.d/20-intel.conf


sudo nano /etc/X11/xorg.conf.d/20-intel.conf

And edit out the information in the file, then ctrl+x to exit, the y key to say yes to save, then the enter key.

Back out of the Recovery Menu and proceed to try to Normal Boot or enter into the recovery Prompt:

sudo reboot

Test if you can reach the Desktop after logging in.

1 Like


Thank you for the detailed guide. But I believe you skipped a step. After selecting Advanced Options for Zorin, I get taken to a page listing:
Zorin, with Linux 5.13.0-44-generic
Zorin, with Linux 5.13.0-44-generic (recovery mode)
Zorin, with Linux 5.13.0-30-generic
Zorin, with Linux 5.13.0-30-generic (recovery mode)

Which one do I select?

You can pick any of the recovery options listed, really. the 5.13.0-44 should work.
The 5.13.0-44 lists the Kernel Version you would be booting up.

Alrighty. Now I'm on this step.

I didn't get any options that say "Drop to Prompt".
Here is the screenshot

What do I select? Did you mean for me to select the "root Drop to root shell prompt"? Or something else?

Root - Drop to root shell Prompt

Ah ha! We did it! Thank you thank you!
I removed the line that had Option "AccelMethod" "uxa".
Now I'm back to square one with the same screen I attached in the first post.

Right now the config file has the Driver "intel". Would you recommend I try something in the guide I liked before?

Good to hear;
Have you run the following command and rebooted, yet?

sudo apt remove --purge xserver-xorg-video-intel

Well, I sudo reboot which was the last step. But I haven't run that command you just listed. What does sudo apt remove --purge xserver-xorg-video-intel do?

It removes (uninstalls) the xserver-xorg-video-intel driver, which can make your system utilize the correct driver, instead of the Xorg Intel driver.

I'm assuming that's the driver that comes preinstalled. But I have not installed any drivers. If it'll make my system utilize the correct driver, then do I need to have another driver installed?

The linux Kernel includes Intel and AMD drivers. These come with the installation of the Distro.
If you are using a Nvidia Card, you may run sudo ubuntu-drivers install, first.

I don't have anything installed other than Zorin and a few apps. No drivers. Just what came with Zorin and the Framework laptop. No Nvidia Card.
I entered the command exactly as you listed. Turned off and on the laptop twice and see no changes. I tried switching Driver "intel" and Driver "i915" a few times. But now they both do nothing. What now?

Is this a 12th gen?

If so... You may need a later kernel than the 5.13.0-44

Nope. This is what it is. But I know it's not a 12th gen.

Let's check.
Can you install neofetch

sudo apt install neofetch

then in terminal, run


It will print your details on the screen, including CPU.

Here it is

What should we do now?

hmmm... very similar to mine...

Honestly, I am at a loss, here...

Paaain. Funny thing is I went into Linux being well aware I have the worst luck with hardware and software when things get technical :crying_cat_face:. I'll wait for another hero haha. At least now I know how to go back to undo what I did if I get locked out again.

Yes, if you look up the "Squares on screen" (graphical issue), you will find the same suggestion I gave you above.