Screen Tearing when connecting Monitor in Portrait Mode

Hello frens,

I recently bought Zorin OS Pro 16 and decided to install them on my Lenovo E14 laptop that I use for work and main device daily and the Lite Pro on an old PC I use as a sidekick.

After the installation and setting the second monitor in portrait mode, I get this tear when I move windows or scroll, it is very annoying and distracting. I searched everywhere, but couldn't find any solutions. It works in landscape though.

I would really like to make it work, as I use it mainly in portrait.

I have only intel integrated graphics card.

Thank you.

Can you please post the output of

inxi -G

I do not use vertical, but I did run a quick search that showed this thread:

The solution offered there actually breaks it even worse. I tried a couple today, this one specifically 2 times and I had to reinstall. One time got login loop with correct password.

have you tried:

sudo nano /etc/gdm3/custom.conf

Comment out WaylandEnable=false by adding a # in front so it looks like #WaylandEnable=false
ctrl+x to exit, then the y key to say yes to save, then enter to save and close.

It is already commented

What about avanish's suggestion here (His is an MS Surface notebook)?

I have tried something similar, but instead of "AccelMethod" "sna" I had "AccelMethod" "uxa". And uxa was what was giving me the login loop. I will try it know and hopefully it will work

Nope, it's worse. Both screens flicker and nothing works, mouse, keyboard. Had to unplug the monitor

So the fix from number 7 worked perfect on Pop OS, currently running Pop. But would love to go back to Zorin. They are both Ubuntu based, shouldn't it work the same on both?

The difference is that Pop OS you have tried are build on a newer release than Zorin OS. Zorin OS follows the LTS release.

You could try with newer kernel and see if number 7 then works on Zorin.

sudo add-apt-repository ppa:canonical-kernel-team/proposed -y
sudo apt update && sudo apt upgrade
sudo apt install linux-headers-5.15.*-*-generic linux-image-5.15.*-*-generic

So, the problem will probably be, possible to solve. Just not now. So I am left with choosing, to wait and use Zorin like it is now, or find a temp distro, till I can be sure the problem is solved.

I have updated my post. You can try it, some have luck with it others don't.

EDIT: fixed the right number of kernel

Just ran the commands, everything went well and restarted. Now apparently I do not have any drivers I think, the WiFi is inexistent, the second monitor doesn’t connect and the main display is showed as unknown. Any tips on this? I’m not sure how I can connect it to the web, not even the Ethernet shows up

Then roll back to the current kernel that works best for you:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.