Screen unusable at random intervals

i have been having a rather annoying issue since installing Zorin OS. i will be doing something, doesn’t seem to matter what, and the screen will turn a colour with lines through it. It has even happened when the pc has been sitting idle. The only way out is to turn off the pc and turn it back on. Any thoughts on what could cause this?

Hi @lderry and welcome to the Forum. Sounds like it could be a video driver problem.
So we can understand your setup, can you please tell us:-

  1. Which version of Zorin you are using? (e.g. Core or Lite).
  2. How did you install Zorin on your pc and if dual-boot?
  3. Some details of your pc hardware. Video Card and how much RAM installed.
    That information should help us to help you.

Zorin core
installed from an iso from usb
2 gb ram
video card :-display
description: VGA compatible controller
product: C61 [GeForce 7025 / nForce 630a]
vendor: NVIDIA Corporation
dual boot with windows 7 home
i suspected a driver issue myself, just not sure how to fix it.

Assuming your settings are similar to this, look under the Additional Drivers tab - any video drivers would be listed there.

@lderry Do check and if necessary change your software sources for installs/updates to Main Server instead of your country source.

settings are similar to those shots. it is set to main server.the only difference seems to be the recommended and important checks below the cdrom[zorin-os option]

Can you give us a screenshot? The settings should be the same (you can ignore winehq and Canonical). If not, please check the appropriate boxes and run the updater again.

It’s happening the same here. Also with the dotted line.
I installed with a usb and have dual boot.
However, I realized that changing the desktop to Zorin instead of Wayland solved the problem.

1 Like

image

Looks fine. Please confirm that you didn’t find anything under Additional Drivers.

You can also try what @pmaranhaor suggested - at the login screen, click the cog next to the Sign In button to select.

1 Like

there is nothing in additional drivers. I’m already on zorin desktop not using desktop on wayland.

1 Like

I looked here under the 7 series (I don’t know if 7025 falls under 7 series, I’m just guessing) and they have Linux 64 bit drivers listed. https://www.nvidia.com/en-us/geforce/drivers/
Can you find your card’s driver and download? We can walk through the installation if the Nvidia instructions are unclear.

There are also some suggestions here but I don’t recommend you try them yet.
https://askubuntu.com/questions/131508/12-04-and-nvidia-card-problem-with-nvidia-geforce-7025#130209 For now just get the Nvidia driver from their website as mentioned earlier.

I found my card listed under the 6 series. There wasn’t any for linux. i found a *.run file on another site. downloaded it. How do i install it?

Right click on the file -> Properties -> Permissions -> check the box for “Allow executing file as program”. Close that window. Double-click on the file.

tried that as instructed. it spins for about 10-20 seconds then stops. nothing else happens.

Navigate to directory where you downloaded the file. Then try chmod +x <filename.run> and then ./<filename.run>