Screensaver kicks in while watching Youtube in browser

Hello everyone, hope you are doing well.
I have a small issue I request you to address:
Whenever I watch youtube videos and the screen obviously remain idle for more than 5 mins(default for screensaver) then the screensaver kicks in. I dont want to kind off disable the screensaver cause it is a good utility but being kicked on when the screen is bound to remain idle is something I am not looking for.
i checked this thing happens for any browser and not only for youtube but also for Odysee.
I am a beginner so I do not know how to fix this thing. Kindly guide me. Thanks in advance.

Is this in fullscreen mode of Youtube?

In normal and fullscreen both sir.

This may be a solution: Caffeine - GNOME Shell Extensions

Ah sorry. I didn't see it was lite version you used. @Aravisian is an expert on XFCE DE so you might want to wait 'til he's online.

No problem sir thank you for replying.

Meanwhile Caffeine is available in the software center. You could try it.

Sure sir I will try it out. Thank you.

In xfce4-power-manager panel plugin, select presentation Mode.

If that does not work, please relay so. There is another fix that is slated to be introduced in XFCE 4.18 when it is released, but the patch exists now and can be used on 4.16.

Sir I use the os on pc so I have turned off power manager. Kindly let me know the other solution.

Please post the terminal output of

systemd-inhibit --list

Here it is sir:

WHO                          UID  USER PID  COMM            WHAT     WHY                                                       MODE 
ModemManager                 0    root 749  ModemManager    sleep    ModemManager needs to reset devices                       delay
NetworkManager               0    root 667  NetworkManager  sleep    NetworkManager needs to turn off networks                 delay
UPower                       0    root 1085 upowerd         sleep    Pause device polling                                      delay
Unattended Upgrades Shutdown 0    root 738  unattended-upgr shutdown Stop ongoing upgrades or perform upgrades before shutdown delay
code                         1000 meet 3808 code            sleep    Application cleanup before suspend                        delay
xfce4-screensaver            1000 meet 1065 xfce4-screensav sleep    Locking screen before sleep                               delay

Here is the patch:

To apply a patch, clone or pull the source file, then use git apply patchfile.
If you have never used a patch before or are uncertain, please say so and I will try to help you with the steps when I am available. I am going to be away fro several hours currently.

Dear sir,
I don't know how to apply a patch. So kindly guide me or point me to a resource for the same as I am not getting something that i can understand online even after searching for it and watching videos for an hour straight.

Actually, we may not need to. I see that above, you said that you are not on Notebook, but on Desktop. Sorry for the runaround...

Can you please open the app menu and type in screensaver
This will offer the Default Screensaver Settings application, labeled simply "screensaver".
Double click to open.
Look to the Very Bottom of the window for a Swtich Box for "Inhibit screensaver for fullscreen applications." That is set to off by default. Switch that to on.
Log out, then back in and test running Youtube in Fullscreen.

1 Like

Yes sir enabling that option helped for fullscreens.
But it still kicks in for usages that are not fullscreen by default, for example when i am in a zoom meeting and am not full screen cause i need to have the zoom chat box window in front of me other than the call. Other case being watching youtube not on fullscreen.
But I discoverd that, even after I turn of screensaver, it still kicks on and the screen goes black. Kindly guide a solution.
Currently, I have set the timer to 180 min so that it does not bother me but the problem is it will kick in when i want it to.

Kindly guide for a solution plzz...

Please have patience. @Aravisian will answer you when he is online and have time.

1 Like

Star Wars Reaction GIF

Normally, Yoda would say patience as well. But he felt an itch, and so he had to get his body moving.

1 Like

Ok sir I am sorry for that.

1 Like