"Scroll Click for scrolling" not working (ZOS 16 Core)

Hi, everyone.

I'm trying Zorin on Dual Boot x W10 on a laptop machine.
I've noticed that the "scroll click" for the SCROLLING function doesn't work. The scroll click itself works fine, like for opening a new tab in Firefox.
However, Windows has this option of clicking the scroll once and "up/down" arrows shows up; moving the mouse in these directions scroll the page.

Also worth noting that the double-finger scroll function works fine for the touchpad.

Cheers!

I don't think auto scrolling is a Linux thing, in Linux is usually made for pasting text instead of scrolling(auto scrolling). You can enable the feature within browsers, but not in applications.

Don't worry, you will get use to it!!

It should be possible to set the property with libinput. Let me try to find out how.


Ok, I think I found it with much crawling around in dusty attics:

xinput set-prop 11 "libinput Scroll Method Enabled" 0, 0, 1

This should already be set to 2 by default, but just in case:

xinput set-prop 11 "libinput Button Scrolling Button" 2

Check that both have been set with:

xinput list-props 9

1 Like

Hey, @Aravisian ! That's so close to what I wanted.
What happens now is that I have to HOLD the scroll click and move up and down as if it was scrolling a scroll bar. The pointer freezes and the content moves; it doesn't continuously move toward the direct I point.

I'm not too good at Linux, but I was reading libinput documentation for Arch Linux and there's a section that says:

Scroll with mouse by holding a button
There is a nice trick to optimize scrolling with a mouse or trackball by holding a mouse button (like right or middle button, or some other if the mouse has more buttons) and moving the mouse. Very useful in case your mouse does not have the mouse wheel (often the case with the trackballs). To do that one has to set ScrollMethod to button and specify the mouse button in the ScrollButton option for the action. Here is an example for configuration to achieve that:

/etc/X11/xorg.conf.d/00-mouse.conf
Section "InputClass"
Identifier "system-mouse"
MatchIsPointer "on"
Option "ScrollMethod" "button"
Option "ScrollButton" "3"
EndSection

https://wiki.archlinux.org/title/Libinput

It obviously doesn't work the same because it's not the same distro (it mentions "Xorg" for this config), but would it give any idea on how to set this for libinput?

1 Like

You are undoubtedly using xorg.
The instructions above say to create a file named 00-mouse.conf in the directory /etc/X11/xorg,conf.d/

Within that file, paste:

Section "InputClass"
Identifier "system-mouse"
MatchIsPointer "on"
Option "ScrollMethod" "button"
Option "ScrollButton" "3"
EndSection

Save the file. Then reboot and test.
I have never done this either, so no idea what effect that may have... :smiley: