Scroll Issues

Hi, I am a newbie and just installed zorin on my xps 13 2in1.
I noticed that I have a line or lag when I am scrolling in the upper third of my screen.

@Aravisian was so kind to help me with this issue when playing video but I haven't fixed it yet.

Here is what I am running for drivers:
hdky@hdky-XPS-13-7390-2-in-1:~$ sudo lshw -C video
[sudo] password for hdky:
description: VGA compatible controller
product: Iris Plus Graphics G7
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 07
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=1920x1200 visual=truecolor xres=1920 yres=1200
resources: iomemory:600-5ff iomemory:400-3ff irq:156 memory:603d000000-603dffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff

I cant even tell if it is a video issue since they work fine but occasionally have the same line in the screen.

Apart from that I love zorin so far :slight_smile:


I notice the clock on the bottom right having a last digit cut in half. Many of these little glitches make me rethink If I should install windows again or is there a way to reset the zorin install?
Headphone jack is crackling too.


Thank you, I followed the first steps and still have the same issue. Now I am on askubuntu and after typing this cmd: ```
sudo apt-get install xserver-xorg-video-intel

hdky@hdky-XPS-13-7390-2-in-1:~$ sudo apt-get install xserver-xorg-video-intel
[sudo] password for hdky:              
Reading package lists... Done
Building dependency tree       
Reading state information... Done
xserver-xorg-video-intel is already the newest version (2:2.99.917+git20200226-1).
xserver-xorg-video-intel set to manually installed.
The following package was automatically installed and is no longer required:
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

How can I upgrade this. Could this be the problem?
sudo apt upgrade
1 Like

I did that and restarted, but the issue persists.

Also when I look into software and updates it doesnt show any additional drivers? Is that normal?

Definitely Normal, That Software is of no Use :joy:

1 Like

Can you please Provide your system specs,
sudo apt install neofetch

eading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
chafa gsfonts imagemagick-6-common libchafa0 liblqr-1-0
libmagickcore-6.q16-6 libmagickwand-6.q16-6
Suggested packages:
The following NEW packages will be installed:
chafa gsfonts imagemagick-6-common libchafa0 liblqr-1-0
libmagickcore-6.q16-6 libmagickwand-6.q16-6 neofetch
0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 5 308 kB of archives.
After this operation, 14.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu/ focal/universe amd64 liblqr-1-0 amd64 0.4.2-2.1 [27.7 kB]
Get:2 Index of /ubuntu/ focal-updates/universe amd64 imagemagick-6-common all 8: [60.9 kB]
Get:3 Index of /ubuntu/ focal-updates/universe amd64 libmagickcore-6.q16-6 amd64 8: [1 647 kB]
Get:4 Index of /ubuntu/ focal-updates/universe amd64 libmagickwand-6.q16-6 amd64 8: [303 kB]
Get:5 Index of /ubuntu/ focal/universe amd64 libchafa0 amd64 1.2.1-1 [42.1 kB]
Get:6 Index of /ubuntu/ focal/universe amd64 chafa amd64 1.2.1-1 [29.7 kB]
Get:7 Index of /ubuntu/ focal/universe amd64 gsfonts all 1:8.11+urwcyr1.0.7~pre44-4.4 [3 120 kB]
Get:8 Index of /ubuntu/ focal/universe amd64 neofetch all 7.0.0-1 [77.5 kB]
Fetched 5 308 kB in 2s (3 262 kB/s)
Selecting previously unselected package liblqr-1-0:amd64.
(Reading database ... 270308 files and directories currently installed.)
Preparing to unpack .../0-liblqr-1-0_0.4.2-2.1_amd64.deb ...
Unpacking liblqr-1-0:amd64 (0.4.2-2.1) ...
Selecting previously unselected package imagemagick-6-common.
Preparing to unpack .../1-imagemagick-6-common_8%3a6.9.10.23+dfsg-2.1ubuntu11.4_
all.deb ...
Unpacking imagemagick-6-common (8: ...
Selecting previously unselected package libmagickcore-6.q16-6:amd64.
Preparing to unpack .../2-libmagickcore-6.q16-6_8%3a6.9.10.23+dfsg-2.1ubuntu11.4
_amd64.deb ...
Unpacking libmagickcore-6.q16-6:amd64 (8: ...
Selecting previously unselected package libmagickwand-6.q16-6:amd64.
Preparing to unpack .../3-libmagickwand-6.q16-6_8%3a6.9.10.23+dfsg-2.1ubuntu11.4
_amd64.deb ...
Unpacking libmagickwand-6.q16-6:amd64 (8: ...
Selecting previously unselected package libchafa0:amd64.
Preparing to unpack .../4-libchafa0_1.2.1-1_amd64.deb ...
Unpacking libchafa0:amd64 (1.2.1-1) ...
Selecting previously unselected package chafa.
Preparing to unpack .../5-chafa_1.2.1-1_amd64.deb ...
Unpacking chafa (1.2.1-1) ...
Selecting previously unselected package gsfonts.
Preparing to unpack .../6-gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4.4_all.deb ...
Unpacking gsfonts (1:8.11+urwcyr1.0.7~pre44-4.4) ...
Selecting previously unselected package neofetch.
Preparing to unpack .../7-neofetch_7.0.0-1_all.deb ...
Unpacking neofetch (7.0.0-1) ...
Setting up imagemagick-6-common (8: ...
Setting up neofetch (7.0.0-1) ...
Setting up libchafa0:amd64 (1.2.1-1) ...
Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4.4) ...
Setting up liblqr-1-0:amd64 (0.4.2-2.1) ...
Setting up libmagickcore-6.q16-6:amd64 (8: ...
Setting up libmagickwand-6.q16-6:amd64 (8: ...
Setting up chafa (1.2.1-1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for fontconfig (2.13.1-2ubuntu3) ...
Processing triggers for libc-bin (2.31-0ubuntu9.9) ...
hdky@hdky-XPS-13-7390-2-in-1:~$ sudo apt install neofetch
Reading package lists... Done
Building dependency tree
Reading state information... Done
neofetch is already the newest version (7.0.0-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
hdky@hdky-XPS-13-7390-2-in-1:~$ neofetch

Now Type
neofetch and provide the entire output

hdky@hdky-XPS-13-7390-2-in-1:~$ neofetch
osssssssssssssssssssso hdky@hdky-XPS-13-7390-2-in-1
.osssssssssssssssssssssso. ----------------------------
.+oooooooooooooooooooooooo+. OS: Zorin OS 16.1 x86_64
Host: XPS 13 7390 2-in-1
Kernel: 5.15.0-48-generic
::::::::::::::::::::::. .: Uptime: 8 mins
+ssssssssssssssssss+:. .:+ssso Packages: 1956 (dpkg), 28 (flatpak),
.ossssssssssssssso/. -+ossssssso. Shell: bash 5.0.17 ssssssssssssso/- -/osssssssssssss Resolution: 2560x1600 .ossssssso/- .-/ossssssssssssssso. DE: GNOME
+sss+:. .:+ssssssssssssssssss+ WM: Mutter :. .:::::::::::::::::::::: WM Theme: ZorinBlue-Dark Theme: ZorinBlue-Dark [GTK2/3] Icons: ZorinBlue-Dark [GTK2/3] .+oooooooooooooooooooooooo+. Terminal: gnome-terminal -osssssssssssssssssssssso- CPU: Intel i7-1065G7 (8) @ 3.900GHz osssssssssssssssssssso` GPU: Intel Iris Plus Graphics G7
Memory: 3089MiB / 15772MiB


Wow I have no clue as to what I am doing here, thanks for your help :slight_smile:

"Enable display compositing"

Settings > Window Manager Tweaks > Compositor

If, this does not work. Try switching from Core (Gnome) to Lite (XFCE).

I dont have that command in my settings

It's in Xfce, Sorry Try the Suggestions in the Link. But, I will Suggest Using Xfce (Lite) version of Zorin. Gnome lags like this are generally fixed by reinstalling it. But, You should try lite this Time :wink:

OMG I just reset the scale from 150% to 100 and no more lag. But everything is so small I can not see things properly. Is there a way around this?

That's Easy.

Awesome that worked too. Last thing how can I make the app icons bigger in the taskbar? I am worried that if I scale it up I run into the same issue?
Thanks again so much.

Can you Provide a screenshot?
How small are the Apps?