Second panel hides below first one when out of focus

Hello experts, hope you are doing good.

I have set up two panels on my desktop, one above the other, for the sake of perfectly setting the dock icons (being in the secondary panel) to the center (without trying to set them evenly using separators, which ultimately gets ruined when a new app is opened and its icon gets added to the taskbar).

But as you can see in the below screenshots, when the secondary panel gets on focus (when clicking anywhere on the primary panel) then the secondary one gets hidden below the primary.

Initial state

Secondary panels hides when I try to access applications

Secondary panel is hidden below the first one when out of focus

I tried to follow this:

and made some changes by myself in the gtk.css file in home -> .config -> gtk-3.0 -> gtk.css but without success.

If you can help in any way then it would be great, thanks in advance.

You have more than one option.

First option, do not have the panels Full Length:

Second option, use a full length thin top bar for Tasklist buttons only (Window Buttons).

Or use a vertical panel on the left or right. There are a lot of different ways of going about this, really...


Thank you sir for the almost instant reply.
Your guide is definitely helpful.
I have tried the second and third option already and used it to my heart's content until I wished to have them centred the windows 11 way.
If your expertise can guide any changes, or else I will switch back to the default configuration or try other configuration based on your guide, no worries there. Thanks.

I am not sure I am following here. Are you saying it is now set up as you want, or are you saying it still needs work?
If it still needs work, what, exactly, needs fixing?

No sir actually I was saying that I want it in the full length way if possible, as I dig it that way.
I am saying that I have already tried the other configurations that you mentioned above in past, and now I want it this way(windows 11 has this type of panel) if possible.

Would having the appearance of full length work?
Let's say you make three panels, like I do in that above tutorial. Only, instead of leaving gaps between them, I have them overlap on the ends by a couple pixels.
Then, in your ~/.config/gtk-3.0/gtk.css file, set your xfce4-panel to have no border.

1 Like

I tried this and borders of overlapping are visible although the border is set to 0px.

Try setting border to be 1px solid and set the background color of the border to match the background color of the panel.

1 Like

Working fine now. Thank you sir for your time and guidance.
Setting border to 0px and border-color to white does not display white borders in dark mode.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.