Setting permissions on the Zorin PC for network share readable from a Windows PC

I am a complete Linux Newbie. I recently installed Zorin OS 17 Pro on some spare hardware I had. The installation went OK and the system appears to be running well. I want to share folders on the Ziron PC so that I can access them from my Widows 10 Laptop. Both from the Home directory and from additional Hard drives installed on the Zorin PC.
The machines are on the same network. Using my Windows PC I can see the Zorin Share but I cannot get access to it. I am sure it is a permissions thing but I just cannot work out how to change thos permissions on the Ziron PC to allow the read write access I want from my Windows Laptop. I would appreciate some advice.

Have you done any sort of setup to share those folders from ZorinOS? My understanding is that you need to set them up using something like Samba. I'm surprised you can even see the folders from Windows, as typically it can't read files from a EXT4 filesystem (used by default in ZorinOS).

One thing you must ensure is that the Zorin PC is in the same Workgroup as the Windows PC. If you did not change the default setting in Windows naming convention of "Workgroup", then you need to make the Zorin PC a member of the same Workgroup.

One way to do it is to make your Public folders on each machine accessible, setting up sharing on each.

Also make sure you are a member of the Samba group (have you installed Samba?).

If you right-click any folder in your /home directory, the context menu includes an item called 'Local Network Share' as shown in the screenshot above. This opens a new window with your options on how extensive you want the sharing of that folder, also shown in screenshot above.

1 Like

Hi yes I have done some setup. Don't want to mess too much and end up with a no return situation. I have already done one new install of Zorin because I had tried all sorts of things previously. I have done the usual on the Zorin PC and shared a folder using the network share function. I have even tried changing the permissions on that folder at the zorin PC. My Windows 10 PC has no issues seeing any shared folders in the file explorer so the browse permissions are set but trying to go further like opening the share usually brings up a password screen requiring a password to login for user sambauser? I am not sure there is even a sambuser. Which is a little weird but I think probably came from when I was trying something else. I have tried changing the user all response either come back to the user & password screen or permissions denied.
I did try at the Ziron PC to access the share from the linux explorer and I cant access it it comes up with "Unable to access location.
Failed to mount Windows share: Permissions denied" So looks like a permissions issue somewhere.

Hi yes I have done some setup. My user is a member of the Samba User group. And for what it is worth the Workgroups are he same as my Windows ones. done the share business on the folder from file manager. Samba is running.

And still no access?

Nope. Going to leave it for now and do some reading.

See if anything in this thread helps:

Finally got it working. I am sure it is not a sound and secure fix but it works. Changed the owner of the folder I wanted to share to my user with the appropriate permissions.
Then used the sudo smbpasswd -a 'user' (my user) and gave it my password.
Then shared the folder , restarted smbd.
And then when using windows explorer to browse to the Ziron PC annd when asked for a username and password used my username and password.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.