Simple-scan dont work on my Epson printer

First Hello,

I installed Zorin OS Core 15 on my laptop but if i want to scan something with my Epson xp-6000 the programm simple-scan dont reconize it.
I already tried to edit the epson2.conf file and add the ip but it didnt helped.
I also installed the Epson driver and their Scan programm but it didnt helped either.
in other Linux distros its work fine to scan without any config change.

i hope someone can help me

Apparently there is a bug report on this issue:

It was patched in Ubuntu, but not backported to 18.04. So it appears that this should be resolved in Zorin 16.

For now, one of the users in that bug report suggested the following:
Epson Iscan

sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane

generate

/etc/udev/rules.d/79-udev-epson.rules

content

#chmod device EPSON group
ATTRS{manufacturer}==“EPSON”, DRIVERS==“usb”, SUBSYSTEMS==“usb”, ATTRS{idVendor}==“04b8”, ATTRS{idProduct}=="*", MODE=“0777”

it didnt helped btw i use the printer via wifi

Maybe this helps, maybe not.
On dependencies and installed files: Simple-Scan - is it working for you?
My own experience, fwiw: Installing Samsung printer and scanner driver

Hey!
I installed already the driver from Epson and there own Programm but it still don’t work. The scanner don’t get reconized but I can print without any problems.

I also had this problem with a canon printer, that works with scangear without any problem.
But then i discovered the site GitHub - alexpevzner/sane-airscan: Scanner Access Now Easy - universal driver for eSCL (Apple AirScan) and WSD
and solved the problem, perhaps also your problem.

2 Likes