Small Menu Text and Icons in some apps

I'm using Zorin OS 17.1 on a Lenovo P15 gen 1.

I have adjusted the scale options in the Display settings and the font size in Zorin appearance. However, in some apps still show very small menu text and icons in places. Two quick apps that I pulled up are Gimp and Stacer withe the side menus. But there are many others where the navigation menus are too small to operate. Anyone have a suggestion to have universal sizings for these?

In GIMP, you can click Edit > Preferences
In the popup window, you can move down to Interface here you can adjust some elemts sizes.
Further down that list is Icon Theme. Click this and then look to the bottom to see a slider and a drop down menu.

  • Guess icon size from resolution
  • Use Icon size from the icon theme
  • Set custom icon size

(I am going off memory, but the above options should be close enough to be understandable.)
When you set custom icon size, that slider at the bottom becomes active and you can move the slider to adjust the size perfectly to your liking.
Or you can try one of the other settings to see if it does the trick.


Stacer is an electron app and as such, carries all elements preset within it for its appearance and does not use the system theme at all. I am not sure if or how these elements can be changed within an Electron built app.

1 Like

Yup just worked for me on Gimp moved my slider to 110 from 100 to be able to see the drop down choices better also changed the icon default to Legacy in the Icon Theme selection .....

Thanks for the tip .....

1 Like

Im not able to see a slider let alone move one, do you have a screenshot?

found it...there must be something wrong here. My icons are so sma ll I could barely see a slider or click on it. I've had to go all the way to "Huge" in order for the icons to be remotely decipherable. there has to be something else going on in my wider settings.

also, to get my pointer moving at a reasonable pace I've had to scale the pointer speed all the way to max too

Odd, you can see it at the bottom of my screenshot:

gimp --version                                                                                 ─╯
GNU Image Manipulation Program version 2.10.18

I have a totally different layout to you...

And you also...

I'm running this version:

Both of yours look way better but it seems Im on the latest version....

1 Like

In my Gimp settings, I have it set to use the gtk system theme.
I am also using a custom Icon theme. I am not using the Symbolic icons.

You may be using the Symbolic icons and that may be why you lack the slider.

Yes you are running a different version ..... I'm on 2.99.18 .....

2.99.18 seems way newer....where did you download it from? I just got mine from the Zorin software store...

I'm assuming you're scaling your display to something above 100%?

If so, two things I wanna tell you:

  1. Be sure to use the default Zorin Desktop option on the login screen when possible.
    You may notice a cog at the bottom right of the login screen, having "Zorin Desktop" and "Zorin desktop on xorg". Changing these changes the back-end that ZorinOS uses for rendering and compositing, and generally the Xorg option is kept for compatibility. Right now there's some issues with ZorinOS' Default session, but they are looking into it and should soon be fixed. [1]
  2. Not all apps support "fractional" scaling.
    Fractional scaling is when you scale the items on-screen to some fraction of 100 or 200%, e.g 125%. Most modern apps support this just fine, but generally this works best on Wayland. When running Xorg, the System has to scale everything to 200%, and then kind of "zoom" it back down to your preferred scale, resulting in some apps being incorrectly scaled, not at all scaled, blurry, or all of the above[2]

So essentially, unless you've been having issues with it, stick to the "Zorin Desktop" option when logging in and try again.

One workaround would be checking if whatever apps you're using has it's own scaling options. For example, many browsers have such options, and any Electron-Based app like the system monitor you're running there can have their scale changed using CTRL & + or CTRL & - on your keyboard. Scale can usually be reset using CTRL & 0 on your keyboard.

GIMP has it's own options too, as you've been explained further up in this thread[3]

  1. It may be useful for you to know that the default option uses "Wayland" for rendering and compositing as it's back-end. ↩︎

  2. at least all of the above where it doesn't contradict itself lol ↩︎

  3. as far as I could tell when quickly scrolling past it ↩︎

1 Like

seems like @Frog is running the GIMP 2.99.x betas.

Yes, I'm scaling my display to 225%.

On the login screen the options are just "Desktop" and "Desktop Wayland". Im using "Desktop" and the issues with Gimp are present.

Sorry I became confused by your post, is it advisable to use "Desktop" or "Desktop Wayland" in this regard?

I've just switched to wayland and now it is picking up the scaling settings perfectly. seems like that resolved it. Same for Stacer too. Looks like Wayland was the answer

oh, is it the other way around? I thought it was "Zorin Desktop" and "Zorin Desktop on Xorg"

Either way, for Fractional Scaling, Zorin Desktop on Wayland should be superior. Just note:

  • Nvidia Graphics support isn't perfect, you may run into issues with that.
  • Zorin's software isn't hyper up-to-date, there may be some graphics issues which have already been fixed in newer versions of GNOME
  • If you experience an issue, you can always switch back to the normal Zorin Desktop (on Xorg).

Same. With Zorin OS 17, Wayland is default. Therefor, it should show the options of the Zorin Default as Zorin Desktop and the standard X11 as Zorin desktop on X.

On Zorin OS 16, however, the X11 was default, so on 16, it was Zorin Desktop and Zorin Desktop on Wayland.

I'm also confused about this, I see those options as well but I've seen another post where they mention those other labels :thinking: