Software Centre doesn't show "Installed"

I'm experiencing the same problem indicated here (Zorin 16 Software Center), some time ago I successfully tried the proposed solution but this time after I did it twice the situation is still the same.
What additional info could I give in order to let you suggest a new solution?

Delete the directory for gnome-software located in ~/.cache/gnome-software

Then try reinstalling gnome software...

sudo apt install --reinstall gnome-software

I tried this but the problem is still there :thinking:
I hope I caught the right ".cache/gnome-software" directory.

There is only one of them, so you would have to.:wink:
Can you try:

sudo apt install --reinstall ca-certificates

killall gnome-software

If in doubt about that directory:

rm ~/.cache/gnome-software

Launch Gnome-Software or Reboot and test...

I tested and it went well but only first time.
Every time I turn on the pc the situation is the same; if I just do "killall gnome-software" and then open Software then it shows normally, but only in this way.

Do you have any added gnome-extensions?
What you could test:

sudo apt install gnome-tweaks

Launch gnome-tweak tool and move to the extensions tab. Disable all extensions.
Reboot and test gnome-software - see if it begins behaving after having removed the cache and restarting. If it does, it indicates an extension conflict and you can begin re-enabling extensions, one by one until narrowing it down on the one causing the issue.
I also wish there was an easier way of testing extensions...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.