Software Updater claims there are software to update but won't install

Zorin 16.3 Pro

Software update states that there are 10 software pieces to be updated.

However, clicking "install" on any of them or "install all" causes no reaction/processing. No indicator anything is updated.

Using this thread: Software-updater stopped updates (which is similar but not quite identical issue).

I have used Terminal (root) to close the store and then to clear the cache. Update list remains upon relaunch of Software Updater.

I have also used other answers from the above linked thread.

Also I have run update-manager from the terminal and this has run successfully and installed updates and now gives a notice that no updates are needed for my system.
Update list remains upon relaunch of Software Updater.

Here is the update list:

How do I clear this list or otherwise resolve this update issue? Thanks

Most of those packages refer to Flatpak, so you can try to update them through the terminal by running flatpak update. I have no idea why the Software Store is not doing it, but hopefully this will work.

Thanks. That solved it. Flatpak seemed to be out of date:

The GNOME 43 runtime is no longer supported as of September 20, 2023. Please ask your application developer to migrate to a supported platform.
Info: applications using this runtime:
nl.hjdskes.gcolor3, org.gnome.BreakTimer

And is now fixed and restarting the Software Updater no longer presents these 10 updates.

Thanks

1 Like

Even if it's out of date, meaning that it won't receive further updates, is still necessary to run certain packages that haven't yet updated to later versions of the flatpak runtime. So this warning is normal, and I would say this is probably more related to how the Software Store handles this situation. Again, no idea why it happened but I'm glad it's solved!

I don't think it is related, but if you haven't done so already, check the source for your updates by starting software updater, then stop it, then click on Settings button. Go to first tab and if your country's server is showing, select the down arrow to the right and change this to Main Server. You may be prompted for your login password for the change to take effect.

Those two can be removed - unless you use Color Picker, or Break Timer... They were removed from my system when I received that as well. Actually, a few apps got the boot - not just those two lol That won't make or break anything so, up to you - won't be getting that message anymore for sure though, if removed.

I'd like to add that, by my experience, the download may look not progressing but may be running “silently”. I saw it maybe twice, I just had to wait a bit and despite the download status animations were static the updates were installed.

2 Likes