Software Updater Crashed My System

I've been using Zorin OS 16 for a few months now. It's been mostly a good experience. However, today I clicked on the popup to install software updates and all havoc ensued.

After a few minutes of performing updates, the entire screen went black with a small blinking underscore in the upper left hand side of the screen. After a few moments, I was returned to the desktop login. I selected my account and tried to log in. The login failed a few times and I think it was the 3rd or 4th try the login succeeded.

Once logged in, I was returned to a blank desktop, all my apps and work from the previous session were gone. I noticed I had no WiFi connection any longer. I launched the settings app and click on Network. I got a messages "oops, an error has occurred", or something along those lines.

Not being able to connect to WiFi, my only option was to reboot.

After reboot, things seem normal I suppose. WiFi came back as expected.

Crashing my system during updates is not something I expect from an otherwise very stable Linux system. I'll go a step further and proclaim that it's actually unacceptable for the updater to crash the system like this. I'd like to figure out what happened and prevent it from happening again, otherwise I'll be turning off updates of any kind.

Any ideas?

I can't solve your problem, BUT i can call the troops...
@Aravisian @FrenchPress @StarTreker @zabadabadoo (and others, even if i didn't mention them)

Is it the sad Face computer image with "Oh no! Something has gone wrong!" message?

I don't recall. I didn't take a screenshot of the error since my screenshot hotkey saves screenshots to network drive, and network wasn't available.

It sounds about right, so I will assume that it is that error.
In terminal, please run:

sudo apt-get clean && sudo apt-get autoremove

sudo apt update && sudo apt dist-upgrade

Once done, try rebooting a few times to test.

I agree with your take, running standard updates should not result in such frustration.

I tried, and got this:

anewsome@force76:~$ sudo apt-get clean && sudo apt-get autoremove
[sudo] password for anewsome:
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.

is it advisable to run the suggested command?

Yes, run

sudo dpkg --configure -a

It appears that during the updates, a packet loss or net-Drop caused a downloaded file to get corrupted.

Those commands seemed to have worked. Thanks for the help.

1 Like

Please mark the post as the solution, thanks.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.