Software updates are stuck - Gnome, Kde and more

Hi guys, been a long while since I've posted.

I'm having an issue with the software updater. It's been stuck (for a few months) on important system updates. There's over 9 of them now. I've tried to find instructions on how to deal with this, but they aren't clear on exactly how to deal with this.

I'm now also experiencing what seems to be kernel issues because my system hangs on a blank black screen with a flashing cursor whenever I power off. And this morning got an error message about the kernel.

And about 3 wks ago, whenever I copy files to my external, Zorin is corrupting some of them, making them unusable and un-deletable.

IDK if that has anything to do with the software updater, but thought I should mention it all just in case.

Any help would be so greatly appreciated!!

In Software Updater settings. Is source set to "Main Server" or a regional/national server?
Main Server is normally considered to be the best option.

Thanks. Mine was set to Canadian servers. I switched it to Main Server... then hit the "update all" to clear up the back logged updates, but it was a no go. With in 3 seconds of clicking it, it went from "Cancel" (because it was going to update) back to the update all.

And the updates are still stuck as before saying "installing" but nothing is happening.

Flatpak or snaps?

One Thing first to clarify: This is not the Software Updater. This is Gnome Software Center Updater.

Did You tried not to use the Update All Button and use insteat the Buttons on each Package? Maybe to install it one after another works a bit better.

1 Like

I am not able to update each individually. If you look at the screenshot you will see it is disabled because they are "installing"... and are stuck that way.

This is the software updater that is in the Zorin menu - for updating all software, not the Gnome updater.

I didn't know Freedesktop, Gnome and KDE come as either flatpaks or snaps. Did you look at the screenshot I posted in my original post? This is all main system stuff that is stuck installing, not programs.

Looks like flatpak. The apps needs differnt framework.

Try:

flatpak update

Well, there was lots to update. I REALLY appreciate the help. I had no clue these were flatpak related. 100 good karma tokens for you!! :grin:

Even though it's updated through terminal now, the software center is still listing them all with "installing" next to them. (same as before) Is there a way to clear those out of there?

And how do I prevent this from happening in the future?

Posting to keep track. I'm having the same issue. If there are solutions, I'd like to know.

1 Like

Might check:

1 Like

In my experience, I'd say that downloads and updates SEEM to be blocked but are actually in progress. In practice, GNOME Software graphically shows us progress that doesn't really match the actual one. In fact, always in my experience, downloads and updates always completed when I did them, I just had to wait.

:pray: super grateful for the help! Thank you, thank you! :+1:

1 Like

Luca, I've been waiting for 3 months... I think its safe to say there's an issue, lol :wink:

1 Like

That is a Picture from Gnome Software. And that has a built-in Updater. The Software Updater is that:

You should find that in System Tools. But to come for Your Stuck Problem I would suggest that You end the Process. First You should disable the automatic Updates in the Settings of the Program. Click on the 3 Lines beneath the Min/Max/Close Buttons and choose Preferences and turn off the automatic Updates. Then let the Program open and open the System Monitor. In the Process Tab You look for gnome-software:

After that You will see that the Software Window will disappear. Start it again and look in the Update Tab.

1 Like

Computer on for 3 months :astonished:?
Tuesday Morning Waiting GIF by RainToMe
:date::face_with_monocle:

Lol, I realized after that this is the Gnome software. I'm really sorry. I'm lacking in linux knowledge. :roll_eyes: I'll get there.

I've actually marked the threat as solved. Storm's post fixed the issue - I'm going to bookmark this thread bc both your answers are fantastic. Thank you SO much for helping me. I super appreciate it!!

2 Likes

No Problem. We all learn every Day new Things. And when it now works is it that what matters.

2 Likes

Good catch. I read the text not the screenshot (facepalm). Zab

@Tink Can you do us a favour by editing your forum profile to indicate which edition of ZorinOS you are using. e.g. Pro, Core, Lite etc. Thanks.

2 Likes