Sogou IM and FCITX

I am struggling to install and use the Sogou input method for Chinese character typing. My first installer said that Sogou was incompatible with FCITX and FCITX must be deleted first. Did that. Install failed.
I am now looking at an install provider who tells me that FCITX is a required support for Sogou.
I am aware that there are many versions of Sogou and it may have been just bad luck that I selected a geriatric one.
Any ideas?

Can you try this .deb package (double click to install)?


With or without clearing out FCITX?
Ido not understand "Changelog"

The documentation says that dependency was removed and corrected - which is why I suggested it. You can install the .deb package by double clicking it to open the installer or by opening terminal in its location and running

sudo dpkg -i *.deb

As usual, the installation process was simple and quick.
But it is not working ... so I figure some kind of settings activity is needed
The (Chinese) webpage that comes with the software says nothing about what action is required ... nor does that Changeslog - as far as I can tell.
Oh ... and I suffered a frozen system crash
Where now?

There is documentation for activating Sogou on this page ... Linux install Sogou Pinyin and Google Pinyin input method(Others-Community)
BUT it most definitely depends on FCITX

This is where me trying to be helpful and me having any clue what I am doing crash into eachother.
I am so ignorant, I only know one language. Ok... well, two... but very, very few people speak the other...
I know that fcitx is a necessary component for Chinese Language only because I had some trouble removing it from my computer.
What happens if you install fcitx?

What is your other language?
Sorry, that's intrusive.
I will find out where I can get FCITX again (it was part of a discarded approach) then install it then follow the bouncing ball from that web page I sent you.
Will let you know how it goes ASAP

sudo apt install fcitx-mozc fcitx-googlepinyin --install-suggest

Fcitx configuration is installed
fcitx皮肤配置向导-UbuntuKylin is not installed. I've read its description and am unsure what it is for - nearest guess "yet another IM"
Change Fcitx 5 Configuration is NOT installed. From what I can see it is very new and may not be suitable.
Fcitx StartIM is installed. whether I should run it is moot. Maybe that just leads down a rabbit hole where Fcitx becomes the actual and inferior IM.
Two more for Fcitx5.

So, install Fcitx has become a tad worrisome at that word "Install"

I think I should just charge ahead on the basis that whatever Sogou wants will either be there or Sogou install will know how to react anyway.

Does that trigger any alarms for you?

You answered while I was typing ... is "--" the break for a comment and therefore I do not actually type "--install-suggest"

No more than the usual alarms you get when you have no idea what is about to happen.
To quote Captain Kirk:
Heading, Sir?

"Out there... Thataway..."

Judging from the comments that flashed by re 6 new packages ... I just installed Japanese.
Now I'll be confident that Fcitx is up and usable and continue following the admin steps on that URL I sent you?

1 Like

Everything looks OK but CTRL-space doesn't react.
Maybe in good old Windows style a reboot will do it ... away we go!

Yep ... Japanese was installed. But I now have a system tray icon ... from which I can take some very head-scratching options ... feel like a 1-year old banging on an iphone to see what will happen.
Time I ploughed through Google to see how to manipulate this thing. I have the Sogou icon in the system tray and can access a configuration dialoge - most of which is more Dutch to me ... so I believe it is there and working and the problem lies to the forward edge of the keyboard.

Thank you for your help

1 Like

I am wondering if @FrenchPress will have any helpful ideas, but suspect she will be interested in Japanese and not Chinese input.

1 Like

I had been using FCITX for years but after I switched back to Zorin, I am using iBus since FCITX is not very compatible with Japanese input method I use (Mozc) in GNOME desktop. There is absolutely no need to uninstall FCITX to use iBus by the way. Both are happily coexist in my Language settings.

1 Like

Hi. French Press. I have the little floating penguin and can click to toggle between Sogou and English. And when I use Sogou but type English words like now, I need two spaces - one to terminate the Pinyin and one to type the space I want. And when I am in Sogou mode, my full stops are full character width。Like that one.
Everything seems to work BUT no Chinese characters are presented or offered.
It is as if it has no idea what to make of "zhongguo" and so just ignores it.
Surely it is an options/settings issue?

This has now become the only thing in this thread that matters to me...

Thank you, Aravisian. Yes, it is as we concluded - Fcitx and Sogou are both installed and appear to be working properly - as attested to by the "little floating penguin".
Sadly, he appears to be floating face down.

1 Like