Solved: installation of CUDA 11.6 on Zorin OS 16 breaks suspend/resume


I recently installed Zorin OS 16 on my laptop with a Quadro M2200 GPU. I used the 'Install third-party software' option which I guess installed an NVIDIA driver with the symbolic links below. I would have to reinstall Zorin OS 16 to confirm this.

I installed CUDA 11.6 from CUDA Toolkit 11.6 Downloads | NVIDIA Developer, selecting Linux/x86_64/Ubuntu/20.04/deb (network) and following the instructions shown. After rebooting suspend/resume no longer worked. If you Google this it is a known issue but some of the recovery instructions only apply to older CUDA versions, for CUDA 11.6 you only have to remove some files.

Looking at my shell history it seems that the following commands removed the corresponding symlinks from /etc/systemd/system:

$ sudo systemctl unmask nvidia-suspend.service
$ sudo systemctl unmask nvidia-hibernate.service
$ sudo systemctl unmask nvidia-resume.service

as my history does not show the rm commands, but again I would have to reinstall Zorin OS 16 to confirm this. Otherwise you can rm these files from /etc/systemd/system.

The other files you have to remove are:

$ sudo rm /etc/systemd/system/systemd-suspend.service.requires/nvidia-suspend.service
$ sudo rm /etc/systemd/system/systemd-suspend.service.requires/nvidia-resume.service
$ sudo rm /etc/systemd/system/systemd-hibernate.service.requires/nvidia-hibernate.service
$ sudo rm /etc/systemd/system/systemd-hibernate.service.requires/nvidia-resume.service


1 Like

Thankfully, I am not a developer using CUDA, but if I were, this post would be extremely valuable. I am someone who gets very frustrated when things break my system for no reason. But as long as there is a work around, thats a solid thing at least.

Take my recent situation, launching steam via the APPS icon in my GUI, causes my system to completely log out! I have no idea why it does that. But launching Steam through terminal using its flatpak command, allows me to launch Steam without logging me out of my OS.

Like I said, as long as there is a work around, then we can still manage. Good deal dude!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.