[SOLVED] Unable to connect to internet through ethernet connection

Hey there!

A while ago I wanted to set up a home server and bought an old Lenovo thinkcenter to do so. I already had a Zorin boot drive so I figured that I may as well use that for the OS (Zorin OS 16). For a long time this worked wonderfully, but there must have been an update recently which has stopped things from working as I can no longer connect to the internet.

The PC sees the connection and knows that it is plugged in, but is unable to verify the connection or access the internet through it, resulting in me not being able to update anything on it and a little question mark on the ethernet connection icon.

I read on some other forum posts trying to solve the issue myself but haven't had any luck yet. Here's some info which may be of use:

sudo lsh2 -C network output

description: Ethernet interface
product: 82579LM Gigabit Network Connection (Lewisville)
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eno1
version: 05
serial: 44:37:e6:45:29:72
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=5.15.0-84-generic duplex=full firmware=0.13-4 ip= latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:27 memory:fe500000-fe51ffff memory:fe528000-fe528fff ioport:f080(size=32)

uname -a output

Linux Server-of-Spenny 5.15.0-84-generic #93~20.04.1-Ubuntu SMP Wed Sep 6 16:15:40 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Some other info / Troubleshooting Steps So Far

I saw this thread with the same network adapter as myself and tried to follow the troubleshooting directions there, but once I downloaded and extracted the .tar file, I was unable to run the commands as there was no ./configure directory within the extracted folder.

I also tried to boot from a previous kernel to hopefully update successfully from there, but that proved ineffective also as I ran into the same issue there :confused:.

I'm really feeling like I've exhausted my resources and understanding reading the existing forums for help and would be incredibly grateful for any troubleshooting help on where to go from here. I've become pretty frustrated because it was working flawlessly for months but only has become an issue in the last week or so. I have loved having my home server and would love to have it back up and running so any help that you guys can provide would be lifesaving.

Thanks in advance guys <3

Hi, sorry to hear of your troubles. Have you checked the integrity of the ethernet cable? Have you tried re-seating the network card? What colour is showing on the network activity LED on the card? You did say you purchased an old thinkcenter so was also wondering if any possibility it might be dying? Lastly, have you tried any live linux to check there are no issues with the network card?


We recently saw a case where a badly connected wire was the cause of an issue with printers... so as silly as it may sound, please do check that the ethernet cable is connected properly.

As @swarfendor437 suggests, please check that is not damaged anywhere along its length. Wires usually don't get much attention and are often placed in such a way that the cable is forced into awkward bents for long periods of time, stepped on, pulled out aggressively, etc.
This last one can also cause damage to the physical ports so please make sure those are also in good condition, with no loosen, out of shape or "splintered" pins. While you are at it, it might be a good idea to rub some isopropyl alcohol using a cotton swab just to remove any dust and dirt particles.

Are you able to ping other devices on the same local network (with Wi-Fi off)?

1 Like

To make another Addition to the Suggestions form the other Two: You could try to restart Your Router.

Hey everyone,

Thank you for your suggestions!

I did try restarting my router, no luck unfortunately.

@zenzen and @swarfendor437
I tried a new cord and no luck either. This is unsurprising though as the place I have my homeserver leaves little possibility of there being any damage to it. I also am able to ssh into the server as normal and can ping other devices within the LAN from it. It is just connecting beyond the LAN to the internet that seems to be the issue.

I also don't think the computer is dying, it seems like this is really the only issue that I've faced so far. When I say old I mean it's like 2015, not being used in an office anymore but certainly not old enough that it should be dying to that extent. To answer your other question though, the led is orange which I believe means that it is connected? Just must be a driver or something within zorin unable to make use of the connection to connect to the internet.

I think today I'm going to try to tether the computer to my iPhone and update that way. When I ssh into the server it does say that there are 191 updates and that estimate was over a week ago, so it wouldn't exactly shock me if one of those made things work as expected again.

1 Like

Usually, LED's are green, orange usually indicates a connection issue. I was not inferring that your computer was dying, but the network card (is it integrated or a PCI ehternet card? If you have other machines with PCI network cards, could you temporarily swap it out to see if it is an issue with the Ethernet card?

Thanks for checking back @swarfendor437!

The tether and update worked like a charm and everything is back to normal.

If anyone else has a similar issue, run sudo apt upgrade to install any downloaded updates first, and if it still doesn't work, tether it to another device like a phone and run sudo apt update && sudo apt upgrade to fetch any new updates and install them.

Thanks everyone for your help!