[SOLVED] Zorin OS not booting up, has been installed for a while now (NVRAM locked)

So, essentially what happened was that Zorin OS stopped working all of a sudden at startup, and won't start up now. I was just using my computer normally, I was trying to install inkscape I think, I installed a package, did something else and left my computer suspended. I came back some time later and turned back on my computer, tried to unlock it and everything worked normally until I realized the login part where I enter my password wasn't working. Apparently there was a "Login error" (The same error that shows when you enter an incorrect password) and I couldn't click the password box or interact with it in any way. I tried changing profiles but my computer was sort of unresponsive at that point, and only my mouse cursor was moving. I then shut off my pc and turned it back on, selected zorin as usual and saw the terminal, also as usual (this doubles as a bug report because for some reason always, even in the bootable usb drive two errors appear at startup), but then I saw some unusual errors, where the pc was suddenly checking the computer or something, like for example "[OK] random thing" and then that many times with different things, I can't remember everything that shows. Then it gets stuck on one command and the only way to get my computer out of that terminal is by turning off the computer and powering it back on, but the same thing happens. I had to go back to windows, create a new usb bootable drive with rufus and then boot up on it. I did the instructions to repair the boot loader as the official page says, but that still didn't work, and I got an error telling me to email an error code. I tried again and I was given a link and told to use it to ask the forums or the boot.repair@gmail.com email. Here's the link: http://sprunge.us/6hiJb3 Apparently there's not access to nvram or something. I'm not very sure of what the problem is, I hope someone can help me! Also some extra information:

I've new to Linux (sort of) I've been using it on vm's for about 5 months now, and I've been using Linux on dual boot for about a month now and I've gotten pretty comfortable installing themes, apps, and using the terminal in general. Still, I maybe did something wrong and broke my system by accident or something. As I said, the problem happened at login. I just remembered I was in the middle of a gedit window, trying to add a shortcut to the apps. I had also downloaded some icons for a few of my apps and I'd changed their .desktop files in the applications folder where they all are. I don't know if that caused the problem when I suspended my pc but I doubt it, as they were just some app shortcuts. I installed zorin with dual boot and I used windows 11. It's not that big of an issue, I'd been doing regular backups with Deja Dup so I can recover most of my files, and I managed to get back the recent files with Linux Reader from my windows partition, so I can probably recover most of my files. Still, I would like to know what can be done. Like, should I remove the partition and re-install Zorin? Or can I run a command from the grub screen that fixes my issue? Thanks!

Pd. Yes I will email the email adress I was told to
Pd 2. Weirdly, I couldn't find any similar problems
Pd 3. I didn't know how to categorize this so I just set it as installing zorin os as most people there probably know more about how zorin works internally.

It looks like this is an NVRAM Locked issue.
There are several things that can cause this; including that some Windows Udpates can cause it to happen.

I agree with you; I doubt it was caused by anything that you were doing.

Sadly, this is an issue that has many causes and therefor, many solutions. You could try clearing your CMOS battery and checking your BIOS EFI settings. This is where Windows can actually interfere with Linux: Windows actually has the ability to communicate with and instruct a motherboard (Which has its own operating system: BIOS. BIOS is a separate OS from Windows or GnuLinux.) per its settings.
Other than that - since you say you have back ups readily available, if this was me; I would wipe and reinstall.
Save yourself the headaches and stress and get a fresh start.


Tysm! I expected I had to do a reinstall. Here are some extra minor things:

Yeah, I expected that, I'm just kinda wondering what nvram is lol

Let's go I didn't break Linux

How can I do that?

Yep, I think I've already tweaked it to be able to use VMs and to disable secure boot to see if that fixed the issue, I didn't really see the other settings though because I didn't want to break anything by accident.

Work smarter, not harder lol. I was just wondering about the CMOS battery. I guess I'll re-install Zorin. Anyways, thanks!

By removing it. :wink: Let the system sit for a few minutes to drain any capacitors.
Then put the battery back in and boot up.

NVRAM is non volatile random access memory.

What you consider as just RAM is DRAM- Dynamic random access memory.

NVRAM can hold data in memory without any power supply, whereas DRAM requires power to be supplied during use. Which is why a reboot clears your RAM.

NVRAM is generally used to hold data that can be applied at Boot, for faster boot or for enabling data to be available for certain parts of the boot cycle.

Welp with my computer model that essentially requires disassembling the whole thing, so...

Ohh thanks for the explanation.

Ohh thanks for the explanation. I also managed to re-install Zorin and back up everything, so I'm fine now. I'm just having some trouble with some dependencies but I'll probably manage to get it fixed. Anyways, thanks!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.