[SOLVED] Zorin os won't install on new system

I'm installing Zorin os 17 via.bootable usb. Error > encounteree an unrecoverable error

Im using New SSD, have no other os on system anywhere. Previously a windows 10 was installed In removed that SSD.

Secure boot, fast is disabled in bios.
Secure boot changed from Windows to Other OS.

Any tips Im trying to install since hours now. I made this bootable usb on windows 10 using balena. That was different SSD which I removed and now using a new SSD.

Did you check the SHA256 checksum of the downloaded .iso file before creating the USB?
Some basic pre-installation advice can be read here: Before you install

What happens when you try and boot the installation USB stick?

Can you open your BIOS and check that USB boot is permitted and that USB stick is listed in the boot device list.

1 Like

A new boot screen with all available options is shown with try or install. I choose Nvidia.

I face this error during installation, after selecting username and password.

I even used a new bootable usb now using Rufus

OK so installer runs from USB.
Try not selecting updates and drivers at installation and see if that progresses further. (you can do those things post installation)

Edit: Rufus maybe preferred over Balena, as the latter has some history of wrecking USB sticks.


Ok doing this time without selecting updates

Continued without entering WiFi. I unticked both Updates check boxes and using Rufus bootable. Worked.

Thanks, silly me wasted hours on this.


Glad you are up and running. If you have Nvidia graphics, you can now progress to picking a proprietary driver that suits your graphics card.
If you reply and indicate which Nvidia graphics you have, people on here can help you pick probably the best one to use. But may be better to start a new Thread for that question.

If my post #4 solved the installation problem, can you tick the :ballot_box_with_check: Solution flag under that post. That may help others find the same solution quicker.

1 Like

Yes I have nvdia graphics. The installation already had drivers, after installing os I didn't had to do anything extra.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.