Sound doesn't work

Can someone help me my sound isn’t working unless I set it to headset and even then only one side works

  • I ran alsamixer and unmuted everything and set everything to full where its red
  • I Open pulse audio control center and made everything unmuted and at 100%
  • I opened sound settings and made sure volume was unmuted and at 100%
  • I also checked the applications weren’t muted in sound settings
  • I clicked on the task bar and made sure my sound wasn’t muted and was at 100%

I don’t understand why there are this many options for sound but none of them seem to be helping.

Are you on Zorin Core or Lite?
What sound chipset do you have?

Also if you are dual-booting Zorin/Windows (unknown) does sound work ok on windows?
If you run Zorin live disk or USB does sound work on that?

Sorry, a lot of questions, but answers may help us help you, although I have personally found sound issues sometimes difficult to address logically on Zorin.

1 Like

I’m on zorin core
I’m not sure what a chipset is but here are my specs…

  • Ram 31.3 GiB
  • AMD® Fx™-4130 quad-core processor × 4
  • GeForce GTX 650/PCIe/SSE2
  • 64-bit
  • Storage 492.0 GB
    I also have Realtek HD Audio support

I am dual booting with windows 10 and my sound works fine there.
I can try booting from USB but If I remember correctly sound didn’t work there either.

Well that is what I have got on my machine and it works, (well most of the time).

If you run Alsamixer and look at Sound Card listing (hit F6), what do you see?

Also take a look at @AZorin tutorial item about audio setup here:

I already unmuted and turned up everything in pulse audio manager

What happens (if anything) if you set Sound Card to “1 HDA NVidia” ?

Like I said above, there is no logic to some sound problems. Sometimes just fiddling about results in it working, then you forget what you did, so not repeatable next time.

I wish you luck. IMO sound problems seem to need a lot of that.


I get this when I select it

@zabadabadoo so I fixed it.
Here was the problem…
I am using my front jack due to my back jack being broke.
I just realized this is for head phones.
Switching to the head phones output in sound settings, it worked! of course then there was the problem of my right sound not working.
rotating the input jack in I continued to test it with right and left and found if I rotated the jack upside down it would connect in a way so both left and right sound worked.

So this was both a issue of my computer being old and broken and me not realizing the front jack was the headphone slot >.>


@Shadowblitz16 . Yay! So you are now hearing the music, great stuff.

I suggest you put a few drops of alcohol (isopropyl alcohol) on your jack plug and work it in and out and rotate in the socket to give the contacts a bit of a clean.

I can try.
I think its was more of a issue of me jamming a larger plug in then it takes.
Also my chair tends to rip the plugs out often so it might just be that the socket it lose.

It is days like this when you start having second thoughts about Linux :rage:

My sound (speakers) failed again.

During startup, ZORIN banner appears, but before the mouse cursor appears on screen there is a “click” heard though the speakers. (I know from experience that is bad news).
Logged in, then Settings>Sound>Speaker Test confirmed - silence from left and right speakers.
I then did my normal (non-scientific) routine of waggling the volume control. Result, no sound.
I then did a Restart. Again loud pop, so again no sound.
I then played with Pulse volume control. Result, no sound.
I then opened Alsamixer in terminal. Checked sliders all in right place and nothing unexpectedly muted. Result, no sound.
Then tried what @Aravisian told me last time this happened:-

I did:
sudo alsa force-reload

Then back to Settings>Sound>Speaker Test - no sound.
Whilst there, I waggled the volume slider a few times and toggled between headphone and speaker a few times. Then heard a faint click.
Speaker Test then reported “front left”, “front right” Yay! about time too.

This time I cannot blame a kernel update as the suspected cause. I did install the new kernel update offered by Software Updater during all that but I had no sound from before that.

So what is it about Zorin and Sound? Why is it so unpredictable?
My magic wand is getting worn out.

I think i had a similar problem. I found out that pulse-audio sound system was not installed (why ever?). I installed it via apt and everthing worked fine.

@herbert Welcome to the Forum. I am glad just installing pulse audio fixed your problem. Lets hope it stays that way.
For me it is erratic. I never know if sound is going to work after any boot. Seems totally random, as if sound is edge triggered but misses the trigger sometimes during a boot sequence and I hear the loud pop though my internal speakers. That is the usual depressing tell-tale that sound will be dead when I log in. I then have to go crazy with volume slider and toggling speaker/line switch in settings>sound, with or without additional reboot to get sound back. Really frustrating, as it is random.

A post was split to a new topic: Sound doesn't work on Acer Gateway NE46Rs laptop