SSD not showing up in BIOS boot options

Hello, I just installed Zorin OS on an ssd. I turned off my computer and turned it back on to boot from the ssd drive, but it doesn’t show up in the BIOS boot options.. My motherboard is an MSI B550 tomahawk

As a first step, can you please try Boot Repair:

Thanks! I just have one question, since I also have another hard drive for windows will I still be able to boot there too ?

Yes, since you are dealing with the Bootloader, not an individual OS.

1 Like

I runned the program, it told me there was an error but when I rebooted, there was an Ubuntu boot option in my windows ssd. I clicked it, and I see some options to boot into zorin, the thing is that I need to boot in safe graphics since it doesn’t work in the normal version (I don’t why, I have a Radeon 6700xt)
but there is no safe graphics options and when I just click the zorin option, it doesn’t work. Picture of options :

Pic of when I click the zorin option : (it’s basically my motherboard loading screen)

Can you select Advanced Options For Zorin and enter the Recovery Menu.
Drop to Prompt


sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="amdgpu.dc=0 amdgpu.dpm=0 quiet splash acpi_backlight=vendor"
ctrl+x to exit, then the y key at the prmpt to say Yes to Save and then enter key to save.
Then run

sudo update-grub

When finished, try booting normally.

Thanks for this fast reply ! I tried that, but the only thing that changed is that I have a few colored lines at the top left of my screen.. pic :

Can you try the steps above, except try:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"


sudo update-grub

1 Like

This removed the coloured lines but my screen’s still stuck at the motherboard loading screen..

Please revert grub to just:

sudo update-grub

Lots of practice doing that, today...

You may need to download and install the drivers from the AMD website:
Which is tricky since you cannot log in, so must do so from the Recovery - Drop To prompt... The command to install is:
./amdgpu-pro-install --opencl=legacy, rocr - Which must be run by changing directory (cd) command into the directory where the file is stored.
So... More practice with terminal using the mv and cp commands...

I am still kinda new with cmd lines, where I exactly should I change the directory to ?

I would just transfer it directly to your Home Directory for ease.
So, with the file on a USB or however you grab it from AMD website and transfer it to your affected computer, boot - then Advanced options... Recovery - Drop to prompt...
Then, replacing $USER with your actual username and media path to actual path:

cp /media/(actual path to usb)/amdgpu-pro-21.10-1247438-ubuntu-20.04.tar.xz /home/$USER/

1 Like

How can I get the usb path in this recovery mode ?

Edit : found how nevermind

Hi again, I have installed the AMD driver on another usb drive and tried to get the file from there but it tells me “no such file or directory” here is the full commands I’ve done :

(i don’t know if you see it all, there should be the command to get all the drives, the cp command and the error)

I just tried a test of this, and it followed on mine. I am not sure why yours is not working. It did remind , though- that tar.xz file will need to be extracted after you move it. Are you certain about sdb1?

tar –xvzf amdgpu-pro-21.30-1290604-ubuntu-20.04.tar.xz

1 Like

I have extracted the file in Windows but it still can’t find it.. I am pretty that sdb but I will try removing the usb to check

I checked if I had the right usb by removing it and checking what was what. I am pretty sure it’s sdb and not something else, I really don’t know what could be the problem, maybe I should try with another usb or by installing the file again..

Edit : I tried with the file put on the usb from the “try it” version of Zorin, but still didn’t work.

Also (maybe this is a stupid question but I am a newbie), should I mount the usb drive ? (If you can do that when not logged in)

Yes, it needs to be mounted in order to be read.

I am sorry, I am multi-tasking heavily as well as running back and forth between the bench and the computer. I realize delays in response are probably frustrating.

1 Like

I just got the file to move to /home !

Don’t worry, I am already very grateful for you helping me, I wouldn’t ask more :slightly_smiling_face: