Steam suddenly is an epic failure

Using Proton Experimental and set to Launch game, not using Vulkan.

Steam installed through APT, not Flatpak.

I am not a gamer, so I am quite ignorant on a lot of this.
I have Valheim installed, Astroneer installed and Creeperworld installed.
All three always launched and worked before.

Recently (I have not launched them in a while) none will launch. You click the button, it flashes for a moment, then reverts to the Green play button. Sometimes, it claims it is downloading content (even though it did that three attempts ago).
It did launch the start page for Valheim - One Time - but there was no sound and clicking any selection on the loading screen had zero effect.

Unmodded, no mod manager.

I have uninstalled and reinstalled all three of the above.
I have install --reinstall'ed Steam
I have remove --purge'd Steam, then reinstalled.
I have tried using Proton Experimental, 8 and 7.

Anyone else struggling with Steam or have any tips?

EDIT: Creeperworld now launches because of magic... And Soul Reaver 2 now will not launch and instantly crashes same as Valheim or Astroneer.

I don't use Steam, never have done. Are the games dependent upob Steam being present? Have you tried PlayOnLinux or Lutris?

I have not due to Steam always working before and due to my limited knowledge on them.

Yes, since I am on GnuLinux and they are Windows games.
Steam is installed.

The only way I can play steam correctly is with a Flatpak version on Zorin. Also has some add-ons at the bottom of the installer through Software that can be enabled; like Proton support.

I've not used either Proton or Lutris - wouldn't be of much help there lol

There is a difference in versions through Software though - ZorinOS has (assuming that's the APT version), Flatpak has

I had to switch to flatpak as well on Zorin OS system On newer released distros this aren't a problem. My guesss is the i386 libs are becoming outdated contra Steam using.

I believe that if I switch to Flatpak, I would lose all game progress files. Please correct me if I am wrong.

It depends. Does your games support cloud and is it enabled?

Yes, but on Valheim, I use a lot of local files, too.

Ehh, that - I would not know... Could back them up and try but, that'd be a mess if it didn't work..

Just searching around maybe Flatseal would be helpful for that, if needed. I don't remember seeing any issues when I was using it (Halo Infinite); I could browse my drive in Steam to look for other games, no problem.

But, uncertain with it.. I haven't touched any Steam gaming in a while - been trying to move back to PC gaming.. PS wants, literally, an arm and a leg to play online now :unamused:

1 Like

What I meant earlier, are the games dependent on a connection to steam or do you have all the files needed to run the games? This is how I played Windows games on Zorin from game CD purchased. First install current stable version of WINE, and I think MONO plus another package I can't remember name of installed, all to do with Windows/WINE. In the fake C:\ drive I would create a folder with the same name as the CD (by this I mean the name that shows up in 'Files'). I would then copy the entire contents of the CD into the newly made folder. I would then select all files with Ctrl+ A, right-click and changed permissions of all files to be executable. Then select setup.exe to run the installer, then launch the game.

The games are downloaded and installed with files located in a local folder. My connection is steady - but I have not tested running any of them Offline.

Ok, I installed Flatpak Steam.
I logged in.

Even though I am logged in, my purchased games are not shown. If I search them - it only offers to sell them to me.

The first one is like a setup guide - the second one, someone has issues seeing their games as well; but seems that Flat Steam likes a different location. Post 5 had something about using a different location - I'm guessing one that Flat uses vs APT..

That's really odd though.. when I got Halo the first time, it was Windows - then booted into Zorin, downloaded Halo and got going.. but didn't pay..... Maybe the paid versions in Flat are just a different location - hopefully :crossed_fingers:

1 Like

Yes, I already found and applied the suggestion to move the game files from the initial home directory to the new ~/.var...` directory. I completed that.
They now show up...
But show up as unpurchased and steam only offers a purchase button.

Is there a way to import your purchases; maybe in the Support page in Steam? I've not made any purchases through Steam myself.. You only have one account though, right?

I have searched the web extensively on this and - bewildered that Signing Into My Steam Account was simply not enough to verify my purchases... I have found no viable answers that make any sense.
I installed Flatseal - and I cannot make heads or tails of how to use it.
And all flatpak installs - Steam and Flatseal, do not show up in the app menu. I must launch each from terminal. There is probably a solution to that, too... But I simply do not care since I only was testing if the Flatpak Package would solve the original issue. The last thing I feel like dealing with is solving Ten new Problems created by Flatpak just to test if it works.

So, I have found a very simple and elegant solution to the Flatpak related issues:

sudo apt remove --purge flatpak

So the Flatpak problem is now solved and I am back to the Original Posted issue.

1 Like

:expressionless: just found out the flat version isn't official Valve.. Bet that's why - I didn't know that.

I installed a new and fresh copy of Zorin OS on another drive.
I then copied my games over to that home folder and installed a fresh copy of steam.

I launched Astroneer... it took forever... But finally did launch. I ran the character around a bit, then exited.
Launched again. It ran and was playable.
Launched Valheim. It spun for a moment... then went back to the green play button without launching.
Launched Astroneer (Again, after trying Valheim). It spun for a moment... then went back to the green play button without launching.


I'm speechless. I have no idea what's wrong. I'm running Ubuntu Budgie 23.10 at the moment - the proton games run as they should, but I have trouble with Stellaris which is native and it quits unexpectedly. But I guess a patch will be out soon to fix it.

It gets even better.
It will not allow me to post to the Discussion section because it claims I am a "Limited account".
It claims I am limited because only accounts that spend more than $5.00 earn the non-limited account.

Let's see... I bought Astroneer for $24.00. Creeperworld was $4.99. Valheim was like $50 or something...
I looked at my account and according to Steam, I have spent




It also says that you can qualify if you have $5.00 or more in your wallet.
I have $25.00 in my wallet. It has been sitting there.

I am pretty much just done with Steam at this point. I plan on contacting them tomorrow and relentlessly pursuing a refund on the wallet contents and whatever else I can get, then Nuking Steam entirely off my machine until the end of all time.

1 Like

Going GoG instead?