Surface Pro Installation Issue

Installing Zorin for the first time and followed the instructions here to get the touchscreen working: Touchscreen not working on Surface Pro 6

But I'm running into an issue installing the repository and now every time I do sudo apt update I get this error:

E: Conflicting values set for option Signed-By regarding source Index of /debian release: /var/lib/extrepo/keys/surface-linux.asc !=
E: The list of sources could not be read.

I'm new to messing with this kind of stuff, is it obvious what I did wrong? Thank you!

Gday @jrodg , Welcome to the community!

This maybe due to an internet issue/unwanted files.
Please run

sudo apt upgrade

Read the output as it will indicate what needs removing/installing. Follow any further instructions from the terminal.
Then retry, Note not all errors matter.

You could refresh your modem/router/etc prior to the update/upgrade.
Hope this helps.
Keep us informed.

Added: A reboot before any of the above may also help.

Thanks for the quick reply Ocka! I got the same error when I ran that command. I would send a screenshot but apt get is not working for me at all now so I can't install a tool to take one...

E: Conflicting values set for option Signed-By regarding source release: /var/lib/extrepo/keys/surface-linux.asc != 
E: The list of sources could not be read.

Edit: restarting did not help either. i can't reset my internet now but i'm skeptical that's the issue...

You need the internet to update/upgrade/install/etc.(Obviously :slight_smile: )
We may need to backup a little here ( start again)
First have you had the machine working prior with Zorin OS(re-install)? Yes i see you state fresh install.
Is this dual boot or Zorin only?
If this is the 1st install, what app did you use to create the bootable usb/cd,?
Those questions 1st ( step by step)

Yes, machine was working fine prior to install. And it is still working fine, it's just apt/get that is having issues. It's Zorion only, and I used rufus to create the boot usb.

Edit: the touch screen is not working fine - that's the whole goal of this endeavor :slight_smile:

Ok as per "Github" instrutions . if you have trouble with the repository then run

sudo extrepo disable surface-linux

Have you tried this?
Please do so if not.

P.s. we only use "apt" now... not "apt-get"

Oooh that's right, I thought I was past the point where that would have caused me issues but it has indeed fixed this issue. I am now running into another but let me debug it for a second before I bug you further :slight_smile:

1 Like

follow the manually install of the repositories.

You may need to disable secure boot, But isee people that are successful without disabling secure boot.
If possible keep secure boot enabled

Added: Source of info for Installing onto Surface Pro.

Also, screenshot comes built in with Zorin. Tap the prtscrn key.

1 Like

Thanks for the help everyone! My second error was the 401 unauthorized mentioned in the guide and I was able to resolve that as instructed, and things are working now. I did not need to disable secure boot so that was nice. I appreciate the welcome and the tips!


Your welcome.
Glad to see you were able to fix the issue,
Could you please mark post #8 as it contains the Github solution.
Enjoy the Zorin OS.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.