Touchscreen not working on Surface Pro 6

Just installed Zorin 16 on my wife's Surface Pro 6. Installation was easy, and she really likes it. Except the touchscreen and stylus aren't working. I see the touchscreen controls under Settings --> Mouse & Touchpad, and everything looks correct. The Touchpad is enabled as are all of the options except side scrolling.

Does Zorin 16 support SfcPro 6 Touchscreen operation? If so, is there something else I need to do to enable this functionality?

As Zorin OS 16 is based on Ubuntu 20.04 the following guide may help you to install the third party Linux Surface Kernel which includes touchscreen drivers:

2 Likes

Probably a bit complex for our current Linux comfort level. I'm ok w/ Terminal commands, but my Linux literacy is not yet advanced enough to feel good about messing w/ kernel installs, etc. Was hoping we were just missing an obvious setting or something. For now, we'll just evaluate w/ the understanding Z16 doesn't natively support SfcPro6 touchscreen out of the box.

Thanks very much for the prompt reply.

A note of encouragement: It is approximately Six Lines that you can paste directly into terminal: I believe in you. You can do it.

1 Like

Heh. That's funny. OK, will give it a try.

3 Likes

:wink: You can do it. If you run into trouble, we are here to help. But expanding your horizons can be a great way to adapt your comfort levels and seize control over the machine you own.

1 Like

OK. Cut-and-pastes complete. That fixed it. I skipped the last step b/c wasn't sure about secure boot, and it booted up fine. Before the reboot, I did the 'uname -a' command and saw 'surface' in the string, so everything seemed to install fine. Touchscreen and stylus both working now.

Thanks for the assistance. And encouragement!

PS - looks like everything is working except the pinch function.

1 Like

Orion, glad to know it went smoothly. I am not sure about the Pinch Function; I have never even used a Surface notebook, much less one with Linux on it.
A search suggests that this command may get that working:

sudo systemctl enable iptsd.service