Suspend mode

When closing the lid of the laptop and the second monitor is connected, the laptop does not go into suspend mode
(Dell Inspirion 17, Zorin OS 15.3)

Are you using Safe Graphics or nomodest boot parameter? If not:
Can you check the configuration file:

sudo nano /etc/systemd/logind.conf

and look for:

HandleSuspendKey=suspend
HandleHibernateKey=hibernate
HandleLidSwitch=suspend
HandleLidSwitchDocked=suspend

Remove the hashtags (#) in front of those lines.
tap ctrl+x to exit, then the y key to say Yes to save, then the `enter key to save and close.
Restart the service:

systemctl restart systemd-logind.service

Check

sudo nano /etc/UPower/UPower.conf

Ensure that the following line is IgnoreLid=true
Again, ctrl+x then y, then enter

and test...

6 posts were split to a new topic: Prevent notebook from sleep on lid close

does not work

Does it work when Second Monitor is disconnected, but does not work when the second monitor is connected?

Yes. It`s right

Is the second monitor set as "Primary" in your Display settings?

No. The second monitor is not set as "Primary"

Can you please try these tips:

If they do not work, I can only suggest switching from HDMI to Display Port, or vice versa.

Thanks. It works

1 Like

P.S. This only works when the extension "Caffeine" is disabled