Synaptic stopped working

On one of my PCs Synaptic stopped working. The Zorin installer still works fine. It sees Synaptic, so I removed Synaptic and reinstalled it. Still not able to launch Synaptic. I tried a couple of reboots. Still no change.

From the Main menu editor, I found Synaptic under System tools and found that the command line code is: synaptic-pkexec When I entered sudo synaptic-pkexec the error returned is:
No protocol specified
Unable to init server: Could not connect: Connections refused

As I searched further, I found a fix: xhost +si:localuser:root

So, now that I fixed my problem, what could have goofed it up to begin with?

I’m afraid I didn’t understand the part about “It sees Synaptic, so I removed Synaptic and reinstalled it.”
Can you enter just synaptic in terminal? It may complain about lack of sudo privilege but it should still load. Just to test that it loads.

To remove and reinstall, please try: sudo apt-get purge --auto-remove synaptic and then reinstalling again with sudo apt install synaptic

I have two ways to install software. The Zorin installer and Synaptic which I added. I removed and reinstalled Synaptic via the Zorin installer.

Synaptic worked fine once I did xhost +si:localuser:root so it must have been a problem with permissions to run the program. I wonder what goofed up those permissions. I think this fix does not persist with a reboot. xhost +si:localuser:root had to be run again after a reboot to get Synaptic running again. Do you know what file should I be looking at to fix the permissions?

It may have something to do with the Wayland desktop:

I think you mean System Tools -> Software when you refer to the Zorin installer, correct?

Some times Software doesn’t ask for root access and can lead to install/remove errors. I recommend running the commands I gave in the terminal.

Yes, I was referring to System Tools, Software.

I did the command line uninstall and reinstall of Synaptic. After a reboot, no Synaptic would not start. Once I entered the xhost +si:localuser:root at the command line Synaptic starts and works normally. Something has messed up the permissions.

If I wanted to undo the switch to the Wayland desktop, how do I do that?

You’re probably aware of this but I’m including anyway:

I need some help here. I uncommented out the line #WaylandEnable=false in custom.conf and rebooted. Now I get a black screen after login. I have been searching for how to drop down to terminal on boot to fix this. Can you help?

I used a boot usb to get to a command prompt and then changed cutom.conf back to #commented. I still have a black screen of death. Do I have to reinstall Zorin?

Follow Aravisian’s instructions here [SOLVED] Black screen after install (exact post linked) to get to the terminal through the recovery menu. Sorry, that’s all I can come up with.


Thanks for your help. I got it back up and running via your instructions and what I also found on the web:

I think I am going to stop experimenting with my system for a while.

Thanks again, Ed

1 Like