System is unusable after a suspension in Zorin Core 16

Hi there, it's my first post in this forum. I've searched for my question before creating a new topic. Actually, there is a topic that mentioned a problem after suspension. But the problem is different from mine. Because of that, I decide to open a new topic.

I've just installed Zorin 16 in my EliteDesk 805 G6 and it’s working great in general. But there is a problem when I resume after a suspension, the system is unusable, with problems in rending the screen, mouse and keyboard are almost unresponsive. The combination ALT+F2 works and I could execute a reboot. I’ve tried some workarounds, like increasing the swap file and checking if the video card driver installed is correct. As you can see in the output of commands bellow, the driver that Zorin 16 installed automatically is a amdgpu
My system is a AMD Ryzen 7, with two SSDs (one with Windows 11 and another with Zorin 16), 16 GB RAM, video card AMD Radeon RX550/550 Series (POLARIS12), version 4.6 (Compatibility Profile) Mesa 21.0.3.

Some informative outputs:

glxinfo -B
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: AMD (0x1002)
    Device: Radeon RX550/550 Series (POLARIS12, DRM 3.40.0, 5.11.0-38-generic, LLVM 12.0.0) (0x699f)
    Version: 21.0.3
    Accelerated: yes
    Video memory: 4096MB
    Unified memory: no
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 4096 MB
    Total available memory: 8192 MB
    Currently available dedicated video memory: 3259 MB
OpenGL vendor string: AMD
OpenGL renderer string: Radeon RX550/550 Series (POLARIS12, DRM 3.40.0, 5.11.0-38-generic, LLVM 12.0.0)
> sudo lshw -c video
       description: VGA compatible controller
       product: Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: c7
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=amdgpu latency=0 mode=1920x1200 visual=truecolor xres=1920 yres=1200
       resources: iomemory:1010-100f iomemory:1000-fff irq:118 memory:10100000000-101ffffffff memory:10080000000-100801fffff ioport:3000(size=256) memory:fc900000-fc93ffff memory:fc960000-fc97ffff
       description: VGA compatible controller
       product: Renoir
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:09:00.0
       version: d8
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: driver=amdgpu latency=0
> swapon -s
Filename				Type		Size	Used	Priority
/swapfile                              	file    	16777212	0	-2

>free -m
              total        used        free      shared  buff/cache   available
Mem:          15340        4963        1157         334        9219        9712
Swap:         16383           0       16383

In your BIOS Settings, what is Thunderbolt Type C Ports set to? That must be set to on.

@Aravisian, thank you for your quick response. I've just watched my BIOS settings now. There is a entry that mentioned Type C ports in my BIOS and is checked on:

USB Type-C Connector System Software Interface (USCI) - checked

I still think it is the AMD driver. Have you tried booting into an earlier kernel?

1 Like

The kernel that Zorin 16 Core installed is:

eldontc@eldontc-zdesk:~$ uname -r

Yes, the 5.11 has had some regressions, though. Have you tried booting into an earlier kernel?
Please see link above.

1 Like

Sorry, I will try an earlier kernel

Is there any power saving setting enabled on the amd card ?

If you have the proper driver installed for AMD, and you are running the proper kernel version for support of your hardware that doesn't have the regressions that Aravisian speaks about.

Michel mentions if you have power saving enabled on the AMD card. You can install the extension bellow to allow you to change the power performance levels of your AMD GPU.

For general disabling of power management, you can do so by entering the following commands.

CTRL ALT T to enter terminal.

xset -dpms


I did a downgrade to kernel 5.4, but the resume after suspension presents the same behavior. The wallpaper crashed and I couldn’t click on any app icons, the keyboard was not working either, and so on.

eldontc@eldontc-zdesk:~$ uname -r

I am a bit confused... You said you moved to the 5.4 kernel, but you posted a uname -r that shows the 5.11 kernel still. Did you boot into the 5.4 kernel?

Please go here to where the crash log should be located. Its a huge file, with tons of text, I don't really know what to look for, maybe Aravisian does, but this is where its located on your drive. I hope this helps...


@StarTreker and @Michel I inspected my bios but there isn't entries for power saving on the amd card. I tried to install de extension dpm control, but I got one error.

@Aravisian Sorry, I did a boot after error and enter with default Kernel, the image was wrong. But I've tried with kernel 5.4.

Some extensions will not work due to a version incompatibility. Just click the X to remove it. Then go to this link and try this one. Sometimes extensions are trial and error.

Are you logging in on Wayland?

Try screenfetch, what does it say?

CTRL ALT T to enter terminal

sudo apt install screenfetch

Then once installed, type screenfetch

Please post results. Screenfetch also shows what kernel is in use, so I am just wondering what it says.

@StarTreker there isn't any file with crash in name or extension in my system. The directory /var/crash is empty

eldontc@eldontc-zdesk:~$ ls /var/crash

Erro for this extension too..

Well, looks like extensions are not going to work for you, sorry to hear it. I did all I could here. Sorry I couldn't help you solve the issue.