Task Bar disappeared

I've just successfully installed Zorin pro 16 lite and wanted to change the "Zorin appearance". As I was sampling each style my taskbar disappeared and I can't get it back. I've tried restarting and desktop settings to no avail. How do I get it back?
Thanks.
Phil J.

hello phil155, try looking here;

Thanks for the reply, dasjdoom.
I tried both of these lines and there is no difference.

Hit alt+f2
Enter in

xfce4-panel --restart

If that doesn't work, just

xfce4-panel

Thanks for the reply.
If I hit 'alt+f2' the only thing that happens is the screen brightness is adjusted.

Sorry, dasjdoom. My reply should have been directed to you.

1 Like

No problem there phil1955, were just here to help each other right.
But Aravisian is the XFCE specialist. Try the commands he advised.

Hi Aravisian. I should tell you that this is laptop (Toshiba, Satellite L50D).
Zorin Pro was working on it, slowly. I had been waiting for the 'Lite' version in the hope that it might be faster. All went well with the installation. The taskbar disappeared while I was changing the 'Zorin Appearance'. I hope the extra info helps.
Thanks
Phil1955

See if the commands on this post on Linux Mint helps:

https://forums.linuxmint.com/viewtopic.php?p=1658467&sid=29cd18a36e887e18fec5149a124fe0f6#p1658467

Change Zorin Appearance to another Layout.
If the taskbar (panel) still does not show up, open a terminal and run:

xfce4-panel

I have no idea why alt+F2 is controlling your brightness... That should be Fn+F2
If the panel appears after running it terminal, then log out and in and ensure it is still there.

I tried the commands on the Linux Mint forum. After the first command, I received the following:
Gtk-Message: 12:09:46.862: Failed to load module "appmenu-gtk-module"

If you want, you can run in terminal:

sudo apt install appmenu-gtk2-module appmenu-gtk3-module

In the meantime, changing the Layout in Zorin Appearance will not remove or uninstall the panel.
It just changes to a specified and preconfigured layout.

Changing to a Familiar Layout and launching the panel should resolve the issue.

Hi Aravisian
This has worked. My taskbar is back - but the command 'xfce4-panel' gave me this lot:
** (wrapper-2.0:5239): WARNING **: 12:25:32.521: No outputs have backlight property

(wrapper-2.0:5234): GLib-GIO-CRITICAL **: 12:25:32.584: g_file_new_for_path: assertion 'path != NULL' failed

(wrapper-2.0:5234): GLib-GIO-CRITICAL **: 12:25:32.584: g_file_monitor_file: assertion 'G_IS_FILE (file)' failed

(wrapper-2.0:5234): GLib-GObject-WARNING **: 12:25:32.584: invalid (NULL) pointer instance

(wrapper-2.0:5234): GLib-GObject-CRITICAL **: 12:25:32.584: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(wrapper-2.0:5234): Gtk-WARNING **: 12:25:32.584: Attempting to add a widget with type GtkToggleButton to a container of type XfcePanelPlugin, but the widget is already inside a container of type XfcePanelPlugin, please remove the widget from its existing container first.

(wrapper-2.0:5234): Gtk-WARNING **: 12:25:32.720: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:5238): Gtk-WARNING **: 12:25:32.872: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner PulseaudioButton)

(wrapper-2.0:5230): Gtk-WARNING **: 12:25:32.944: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner GtkToggleButton)

(wrapper-2.0:5239): Gtk-WARNING **: 12:25:33.446: Negative content width -1 (allocation 1, extents 1x1) while allocating gadget (node button, owner PowerManagerButton)

You can ignore all of those warnings.
These warnings can come and go... as portions of the code get deprecated or changed or additions are made in updates.
It's pretty normal and gtk loves to complain.
Have you logged out and in to ensure the panel stays put?


As an aside and speaking as a themer... I find the Negative content width -1 annoying because when making a theme, those plugins must be isolated from the other plugins and given a -1px margin to account for that 1 pixel allocation mismatch.
I wish the XFCE devs would fix that...
Example:

#xfce4-power-manager-plugin, #sn-button {
min-width: 40px;
margin: -1px;
}

Sorry Aravisian,
I've returned to my laptop after a few days (busy!). It booted up OK, but no taskbar again. I tried running the install command in your post but - nothing/ I get the line:
appmenu-gtk2-module is already the newest version (0.7.3-2)
in the terminal.
Phil J.

If I try to access the panel in the settings manager, I get the following message:
GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.xfce.Panel was not provided by any .service files
As you've probably guessed by now I'm not tech savvy. I use Zorin Pro on my desktop and I'm very pleased with it. So far, this Pro Lite version is faster on my aging laptop despite this niggle.
Thanks for your time
Phil J.

Can you try:

sudo apt install --reinstall zorin-os-lite-desktop

Thanks, Aravisian
Sadly, no difference.

I just ran 'xfce4-panel', again. I got all of the warnings again, but my taskbar returned!

1 Like

Glad you managed to solve it! Life without taskbar is tough.