Terminal doesn't open after installing Python 3.9

I have a problem. I installed Zorin OS 16 and one of the first things I did was updating python. Everything worked, until I restarted the PC. Now the terminal doesn't open at all. I can't press CTRL + ALT + T and I can't open it through the main menu. Please help me! I really need it!

Could please clarify what do you meant by "can't press"?
The keyboard is not working?

If I do this key combinations the terminal doesn't open.

Thanks for the clarification.
Are you using Core or Pro edition?


Just tested on both 16 Core and Pro editions.
The terminal shortcut is working for me.

I wonder if there is a conflict of the shortcuts.
We need a Python specialist.
I wonder if @Aravisian might have some idea.

The problem is. That I can't open it at all. Even if I click on the icon.

Ah, OK.
You did not tell me that in your question :wink:
No way to guess that one.

If that is the case, you can use Software to uninstall/reinstall Terminal and see if that fix the problem.

I already tried it multiple times. It doesn't work. :pensive:

Another way to deal with software is through Synaptic.
Could you install Synaptic Package Manager in Software?

1 Like

Okay. I have installed it. What now?

Open Synaptic.
It will ask you a user password. That is normal.
Search for gnome-terminal.
And tell me the result.

Mine looks like this:

This is my search result.

which python you installed ?

The newest version of python. Python 3.9.6. At least I think this is the newest one. I followed some guides on the internet how to install python 3.9.

You mean something like this? (this is for the older version 3.6 though)

You can try this.. but change to your Python version.

For terminal stuff you can install another terminal

No. I followed a guide more like this...

I was just about posting this link, but you beat me :wink:

So it seems my first hunch about python issue is in a right direction.

1 Like

So I'll look at the guide...
I'll tell you the results a bit later...