Terminal doesn't open after installing Python 3.9

I had to help.

Seeing a person so distressed over being unable to access the Terminal...

you are my hero :smiley:

So now pyhon3 is linked to python3.8 which is required and I can still use python 3.9 with the command "pyhton3.9". Great!

I'm really thankful!

I am glad that you finally made it work.
Please tick the posting which solved your problem and :ballot_box_with_check:
to mark the thread as solved.

1 Like

If it were the GNOME thing, then XFCE desktop should be immune to this issue.

So you can install python3.9 following guides and after that you have to reinstall python3, python3-minimal, python3.8 and python3.8 minimal that everything works properly. You can also use this to install python 3.9 on your computer. (You should have a backup if you try this because I don't know if I'm right with this. :wink:)

This really is part of the trouble with some internet guides. And I have been a bit harsh on this forum before about internet guides, too...
Worse is when an outdated guide remains published on the web forever, misleading users and resulting in breakage.

XFCE is modular. When I was using Gnome on Zorin, I installed just xfce4-terminal and used it. It worked fine.

It seems Alpha-Craft made it work thanks to the advise from Aravisian :slight_smile:

That is an interesting information.
I was not aware of it.

It reminds me of the shift to those multifunction office machines.
All-in-one = Fax + Printer + Scanner.

In the old time a printer still works even a scanner/fax is down and vice versa. But not any more. If one thing fails, it will take down everything with it...

1 Like

This is very true... And one really good reason to enjoy modular. Whereas gnome has so many interdependencies... You can run just xfce4-panel on another desktop in order to get a workable and customizable panel. Or the terminal. Or the File manager Thunar. LXDE is the same way.

I have solved the issue by changing back my python version from 3.11 to 3.8 with the command below

sudo update-alternatives --config python3

Make sure to choose the input option for python 3.8 as showed in screenshot below:

image