That was a BAD day - Macbook Air 2019 no WiFi, no keyboard, no mouse

wow - this was a disappointing bad day: I bought a mint Apple MacBook Air 2019 for the sole purpose to install zorinOS on it, encouraged by the last two weeks on different systems with it.

But very soon I hit a really big roadblock, the boot takes 15 minutes, a lot of errors before and: NO wifi, NO keyboard, NO touchpad = mouse

And, NO way to circumvent all three of them on a MacBook Air with only two USB C interfaces. I tried to use an (Asus) port replicator with an old USB A port and the Apple cable keyboard and an USB wifi adapter.

I can use external Apple keyboard and cable mouse, but was not able to power the USB WiFi adapter.

So, even if all of that three will work (which is NOT the case) - I really don't know how to go the next step (fixing the missing drivers for key, touch and wifi).

Any ideas to solve the miracle without buying new hardware?

PS: I read a lot of tutorials / howtos on the steps in preparing the Mac, and also a lot of articles about adding drivers (but I'm missing the knowledge and experience to do so...)

You really hit it right here.

The forum can certainly try to.
Perhaps with total success, perhaps partial. Perhaps none.

Apple - as a company... Is even more proprietary than Microsoft is.

When it comes to Apple Products, it is always a gambit. Apple provides the hardware and the Operating system. Microsoft only supplies the Operating system.
So, Apple is more motivated to protect both.

Back to your direct question:
The newer MacBook Air notebooks require specific kernel DKMS software:
GitHub - AdityaGarg8/t2-ubuntu-repo: APT repository for T2 Macs

You need Net access to do this- so if Mobile Hotspot or Ethernet is available, they are your friend.
Add Repository Key:

curl -s --compressed "" | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/t2-ubuntu-repo.gpg >/dev/null

Include repository in sources:

sudo curl -s --compressed -o /etc/apt/sources.list.d/t2.list ""

Update apt to see the packages within that repository and install the software:

sudo apt update && sudo apt install apple-bce

Modprobe that puppy:

sudo modprobe apple_bce

If you need the module to load earlier than Login, for example if you are using LUKS, you will need to take further steps. Which... I need to look up how to... It's easy... I just don't remember the steps...

That should get us started. Wifi should be a standard driver in the kernel, so we can troubleshoot that next.

EDIT: Is Touchbar the Touchpad?

1 Like

no ethernet to USB C or A here, but what did you mean with Hotspot?

Touch Bar is the replacement for Fn keys in the top row on some MacBooks (not mine) - touchpad is the "mouse"

shouldn't it be possible to "bake" the additional necessary parts into the boot USB stick? That way would make the whole setup much easier for me / for all in that situation?

1 Like

There is am Ubuntu-Based distro that has done this...
Let me find it.


That being said...
The above commands - there were three of them... You can do this. It's easy.
Perhaps having someone else do that for you is technically easier, but why bother?
I mean... once you are on the distro of your choice, you will need to run a command or install something or remove something... There's no getting out of it.
So why avoid running one installation now, that is quite easy to do... Only to have it unavoidable later, anyway?
It makes more logical sense to become comfortable with retaining control over your own computer now. Being able to fish tomorrow, than to seek a fish supplier tomorrow.


yeah for sure I will try that, if I have solved the problem with the initial network connectivity. As far as I can oversee it, I HAVE TO work with and external USB C dock which allows me to connect

  • external USB keyboard
  • external USB mouse
  • ethernet adapter


  • third USB A port, which is powered and will work with external USB A WiFi stick

to clarify what I meant with that is: I want to prepare an bootable USB stick on my other notebook with these changes already done while connected to the internet, than have the necessary parts on the USB and boot from it

@Aravisian thank you, I have now understood what you have meant by "hotspot" and connected my phone via bluetooth to the zorinOS booted from USB. I passed all your given commands into terminal (it took a while) but everything went thru except one error in the end (... can't connect to zsys daemon....)

but after the last command, the keyboard on the MacBook was functioning again and same for the trackpad.

What I DIDN'T get to work is WiFi and everything related to function keys / media keys.

I will keep reading and trying seeing in which direction that leads...

But it was a first successful step in not throughing that new MacBook into ground :wink:

1 Like

I am sorry for the delay.
I was working on some important tasks.

sudo systemctl restart zsysd.service

sudo apt install -y bcmwl-kernel-source

You can use Clonezilla or Rescuezilla to create a bootable customized snapshot of your Zorin OS from that build.

so a short update from my side: I jumped the shark and have partitioned and installed Zorin instead of booting from the USB thumb drive.

The keyboard / trackpad works after the given commands, but only until reboot.
So even selecting the user and typing the keyboard doesn't work correctly.

And WiFi I didn't succeed.

At least, the dual boot works as desired.

Any new ideas on how to make it work?

Kindest regards


so I've made a huge step in the right direction with the help of this:

keyboard and trackpad work like a charm, every single key including all media and special Fn keys for screen brightness and keyboard brightness and volume keys.

I even managed to get the WiFi working with the help of that guide, I highly recommend for everyone dealing with newer T2 chipset aka all nexer mac / macbook since 2017 2018 2019 2020 but NOT the M1 or M2 Apple silicone one.

ONE STEP is missing: the WiFi is lost after reboot - for sure I'm missig something but don't no what exactly

here is the output from the last command on the site:

Nov 30 15:23:38 chris-MacBookAir kernel: usbcore: registered new interface driver brcmfmac
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac 0000:02:00.0: enabling device (0000 -> 0002)
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4355c1-pcie for chip BCM4355/12
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac 0000:02:00.0: Direct firmware load for brcm/,hawaii-YSBC-u-4.3-X3.bin failed with >
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac 0000:02:00.0: Direct firmware load for brcm/,hawaii-YSBC-u-4.3.bin failed with err>
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac 0000:02:00.0: Direct firmware load for brcm/,hawaii-YSBC-u.bin failed with error -2
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac 0000:02:00.0: Direct firmware load for brcm/,hawaii-YSBC.bin failed with error -2
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac 0000:02:00.0: Direct firmware load for brcm/,hawaii-X3.bin failed with error -2
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac: brcmf_c_process_txcap_blob: TxCap blob found, loading
Nov 30 15:23:38 chris-MacBookAir kernel: brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4355/12 wl0: Sep 14 2022 23:33:16 version 9.30.489. FWID 01-6>
Nov 30 15:23:39 chris-MacBookAir kernel: brcmfmac 0000:02:00.0 wlp2s0: renamed from wlan0

and of course, and again - thank you very much @Aravisian for your kind and endless help!!! Without you, I would have quit very early and I'm sure many others too...

1 Like


This guide below suggests Not using the bcmwl-kernel-source for wifi and instead to use b43-installer. It is worth reading and the steps are laid out well to make it easy to follow:

yes there are some how to floating around - it seems to be heavily depends what Macbook / which build / which year is the target of the installation.

On my older Macbook Air from around 2010 (I wrote earlier about that) I could boot from USB and EVERYTHING worked right out of the box (or stick ;-))

The never ones around 2017 with T2 security chip, I found the T2 linux wiki very helpful.

so another short update on my journey with a T2 Macbook Air 2019 and zorinOS 16.2 core:

the T2 wiki has also an associated discord. The folks there have been very patience and helpful with all my newbie questions, and solved the problem, that after every reboot I lost the WiFi again and had to manually re-enable it.

After I few (mystery at least for me) changes everything now works as desired on the Mac.

If you are interested, you find the solution in the ubuntu general section or if you search for my handle "xabbu" there.

So at least, I have to excuse my over-emotionalized" headline to this thread, forgive me for that...

1 Like

I have a macbook pro 2019 and did run into the same topics. No keyboard, no touchpad etc. working. - After reading a bit in the existing T2 wiki, it seems there a some distributions including already all the needed adjustments. They are for free. I am a little bit disappointed to be hones, i did buy the pro version of ZORIN struggle to get it up and running in the first place, even it specifically says also MAC installation instructions. :frowning: - Lets see how i get it working without loosing my mind ...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.