The Dreaded Peril of installing libc6-i386

sudo dpkg --add-architecture i386

sudo apt-get update

Dangerous Command - Do not Run:

sudo apt install libc6-i386 libx11-6:i386 libegl1-mesa:i386 zlib1g:i386 libstdc++6:i386 libgl1-mesa-dri:i386 libasound2:i386 libpulse0:i386

1 Like

DO NOT DO THIS COMMAND

1 Like

Why ------

32 dependecies for 64 bit system

1 Like

@Creepdasheep
Are you running a 32bit build on a 32 bit computer?

Architecture: x86_64

Ok, running the above command will destroy Zorin OS, most likely irrecoverably resulting in Reinstalling the Operating System.

Oh okay good thing my pass is long cuz I was half way typing it though

Yeah... Good thing I happened to look in the thread... I saw three minutes had passed since that was posted...

What that would do is not just install libc3-i386... It would remove the 64bit build of Libc6, which would remove the essential compiler as a dependency.
This would autoremove the Zorin OS Desktop and most other essential packages.

2 Likes

I dont get that, even lutris posted this for minecraft

64bit systems needs 32bit dependencies:

Thats Bedrock I use java and minecraft.net has a download for Linux but thouses are the 2 games i have

I edited the above post for clarity.

Trust me on this... It would destroy the OS... And I would add that link to the Wall Of Shame.

2 Likes

I trust you, but if i am not wrong i used the same command on my os and nothing happend

Steam needed 32 bit dependecies as well if i remember right

It happened to another member recently and wiped his Zorin Build off the planet. I can go try to find that thread...

I have also... in the past... made the mistake of installing libc6-i386 and destroyed my build of Zorin.

3 Likes

Ill try those commands tommorow on my test drive

1 Like

What should I do about the lag

Should i just go back to windows?

The only thing you can try is to tweak the setting in game. Turn off shaders or lower them to see if it has any impact.

This thread.

OP was given a wrong advise to install a propitiatory driver from Synaptic (which is impossible). I was not fast enough to come to the thread to stop the disaster :frowning:

Why does everyone say it is save

https://zoomadmin.com/HowToInstall/UbuntuPackage/libc6-i386

Read the posts in the ubunt one