The "." it is written without me pressing it ._

What about Windows?
You can download and install it and test it without registration during a grace period (last time I checked it was 3 days).

I use a separate disk with Windows 10 and I did not have this problem

What about MXLinux?

It is a Debian base not Ubuntu base.

Before this did not happen very often, yesterday I received an update and now it happens much more often and faster

The only thing I can suggest is to run a live session on non-Ubuntu based distro and see if this keyboard issue still happens.

I gave you a link to MXLinux above, since it is the one of the easiest Debian based distros.

Ok I'll try

I already tried MXlinux and it doesn't have this error

If that is the case, I recommend you to use MXLinux.
I visit their forum time to time since I am running a server with MXLinux.
Their forum is quite beginner friendly.

I have a question, is this a notebook computer? Does this continue doing it when the keyboard is unplugged? Because if it still does it after the keyboard has been unplugged, then I am suspecting the internal notebook keyboard is faulty, specifically that period key.

This is a strange issue indeed, and I am really hoping that we can help you solve it!


Your Tech Support Guru

It didn't work :rofl:, Keep happening

Could updating the BIOS fix this error and the graphics problems I'm having?

Actually, updating the BIOS could possibly fix the issue if the problem is due to lack of hardware support in your current BIOS. But I am going to tell you what I tell everybody who wants to do a BIOS update.

Most motherboards are not fancy enough to have a BIOS recovery flash back switch. Basically, its a featured that fancy motherboards that have two BIOS's on them, you flip a switch and it goes back to the previous BIOS.

So, having said that, your going to want to have two USB flash drives at the ready. One that has the original BIOS backed up on it, and another drive that has the updated BIOS on it. This is for incase the BIOS update goes bad, you can reflash it back to the original to get you going again.

We here however are not the manufacturer of your machine, so you should follow all guidelines and instructions on the website for your machine, when it comes to doing a BIOS update. Some computers can be flashed from the OS, but thats usually on Windows.

So ya, my main recommendation if you do a BIOS update, is to always have the original BIOS handy incase you got to flash back.

From what I've seen on other forums, Someone with similar bugs to mine (Graphics, Instability, and boot issues) have solved it by updating their bios (They also had these Skylake Family CPUs)

I will also do it because my BIOS seems that at the beginning it had very bad support since it has many visual errors (such as badly positioned text in the manufacturer's logo and it works quite slow)

Thanks for the recommendation to back up the original BIOS, I read that doing the process wrong could damage my PC :neutral_face:


Hi, I already updated the BIOS to the most current version, I fixed the problem I had with the instability and the fan but Zorin keeps writing alone and I already tried absolutely everything

And you have checked that Sticky Keys and Slow keys are disabled?

Other than that, hardware is the only thing I can think of:

I hate sticky keys

Cinnamon Roll Food GIF
It happens when you eat too many of these in front of your computer.

Good advice from Aravisian, please make sure those are disabled.


Yes, this option is disabled.

Already Disable this option to keep the keys pressed, but the error still persists

I do not know if it is useful, but this usually happens when I spend a lot of time without writing, when I do many things at the same time and when I suspend the laptop.

I was able to partially fix the problem using this command

sudo -H gedit ~ / .Xmodmap

in the created file I put the following

keycode 60 = NoSymbol

and the problem was partially solved, It no longer happens in daily use and the system is more fluid (I have no idea what that had to do with the stability of my system)

but the error still occurs when suspending the PC completely (Al lowers the lid of the equipment) but then when touching a key it stops


It's been 7 months since I made this post, and I still haven't been able to solve the problem even trying a thousand things from a thousand different pages and installing Zorin more than 40 times XD

I think it is the hardware. :wink: