Top bar not showing up in Screen 2

I am using Zorin 16 core and layout 4 (Typical Gnome layout).
When I connect an external screen as screen 2. The top bar only shows in Screen 1 and not in screen 2 is there any option to enable top bar in both the screen.

Right click panel, taskbar settings... POSITION...

This might also be helpful with these settings here, such as setting workspaces on multiple monitors. Found in Gnome-Tweaks

In layout 4 the taskbar setting is disabled and the option two mentioned too didn't Help.
Attaching the screenshot for reference.
As you can see no top bar in Screen 2 (left side) top bar is only available in Screen 1 or primary monitor(Right side)

Maybe this will help?

https://extensions.gnome.org/extension/921/multi-monitors-add-on/

You can activate extension and adjust them via the extension menu in Zorin. You can also do it from tweaks, if you have Gnome-Tweaks installed.

2 Likes

Thank you so much @StarTreker. Exactly it solved the issue.

3 Likes