Touchpad gestures not working

My touchpad is an Alps I2C:

cat /proc/bus/input/devices:
I: Bus=0018 Vendor=044e Product=121e Version=0100
N: Name="AUI1667:00 044E:121E Mouse"
P: Phys=i2c-AUI1667:00
S: Sysfs=/devices/pci0000:00/0000:00:15.0/i2c_designware.0/i2c-1/i2c-AUI1667:00/0018:044E:121E.0001/input/input3
U: Uniq=
H: Handlers=mouse0 event3 
B: EV=17
B: KEY=70000 0 0 0 0
B: REL=1943
B: MSC=10

And touchpad gestures will not work, and I do not know how to solve it. I tried changing some mouse-related settings in both Settings and in Gnome Tweaks.

Are you using Zorin 15.3 - Lite or Core- or Zorin 16 Beta?

Is this a recent installation and touchpad gestures are new- or an existing installation in which touchegg has stopped working properly?

Oh! Sorry, I forgot to clarify that! It is a brand new installation of ZorinOS 16 (Core, obviously).

Your touchpad is being detected as a mouse, instead of a touchpad.

Sadly the only repair I know of is to Update the Kernel or install a backport kernel.
Have you done

sudo apt full-upgrade

since you installed?

Update the Kernel or install a backport kernel

How would that be? I have Linux v5.8.0-50-generic. But I know nothing about backport kernels.

Have you done sudo apt full-upgrade since you installed?

Yes sir.

I am a bit baffled too... the 5.8 kernel should be good.
You might try

sudo apt install --reinstall touchegg

just in case...

That didn't work.

Could it be because it is both Alps and I2C? I never tried getting gestures in Linux, but in Windows 10 I don't have all the gestures and (trackpad-related) animations other people get. Also, I installed macOS in this laptop and in there, there is no way to get Alps I2C touchpads to work (anyway, It's a hackintosh so it doesn't make much sense to compare, but maybe that information is useful).
The point is: maybe this trackpad is not very gesture-friendly (however Windows got it to work pretty well, so it would be really nice if there's a way to make it work here in ZorinOS).

Since the driver doesn't seem to be the issue, try this:

sudo apt-get install i2c-tools


Another possibility would be to enter the bios and change the touchpad setting from advanced to basic. Hopefully one of these solves your issue. I'd try the software install first.

Without knowing your laptop model in stabbing in the dark.

can you login with wayland? try that

I installed i2c-tools (didn't work), but I can't modify that in my BIOS.
This laptop is a Lenovo IdeaPad 330-15IKB 81DE.

Yes, I can, but that seems not to be enough to solve this issue.

...And will break everything else...:stuck_out_tongue:

to make gestures work outside wayland you need to install some other libraries/extension.
try GitHub - JoseExposito/touchegg: Linux multi-touch gesture recognizer and GitHub - JoseExposito/touche: The desktop application to configure Touchégg for the gui