Touchscreen double-taps on single tap

Hello! I've got Zorin 16 Core (latest 5.13 kernel and all up-to-date) double-booting with Windown 10 on separate partitions on a Dell Optiplex 9010 AIO touch.

An odd issue I came across recently was that the touchscreen seems to read a single-tap as a double-tap - but only after restarting or putting the PC to sleep (I don't use hibernate), so it behaves properly after shutting the machine down and then booting back up. The touch functionality works fine in Windows.

I've looked up and down and tried a few things - booting to an old kernel, calibrating the touch display, and lastly I considered updating xinput (but is this possible or recommended...?). I wonder if it could just be a driver that's way too old at this point and plays up, but I thought I'd pick your brains first and ask you to give me an idea what to look at to troubleshoot this. (Happy to report that my Synaptics-driven laptop touchscreen performs perfectly fine under the same OS.)

I tried to collect some data to get you going, please see below. Also, a screenshot of part of my log that I thought was relevant but couldn't figure out if there was anything wrong with it.
P.S. I don't use any other gnome extensions besides the built-in save for ArcMenu.

Any help is appreciated!

  Kernel: 5.13.0-27-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13.0-27-generic 
  root=UUID=e153de15-05f8-449b-ab10-ac08963cbc73 ro quiet splash 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 
  Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal 
  Type: Desktop System: Dell product: OptiPlex 9010 AIO v: 01 
  serial: <filter> Chassis: type: 13 serial: <filter> 
  Mobo: Dell model: 0CRWCR v: A01 serial: <filter> UEFI: Dell v: A25 
  date: 10/19/2018 
  Device-1: hid-00:18:00:3e:f9:77-battery model: Convertible 2 TKL 
  serial: N/A charge: N/A status: Discharging 
  Topology: Quad Core model: Intel Core i5-3470S bits: 64 type: MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23148 
  Speed: 1687 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1687 2: 1613 
  3: 1610 4: 1748 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics 
  vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0152 
  Display: x11 server: X.Org 1.20.13 driver: i915 compositor: gnome-shell 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1) 
  v: 4.2 Mesa 21.0.3 compat-v: 3.0 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k5.13.0-27-generic 
  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e 
  v: kernel port: f080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: eno1 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6235 driver: iwlwifi v: kernel 
  port: f040 bus ID: 02:00.0 chip ID: 8086:088e 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 232.89 GiB used: 22.47 GiB (9.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 043 scheme: GPT 
  ID-1: / raw size: 57.26 GiB size: 56.11 GiB (97.99%) 
  used: 15.19 GiB (27.1%) fs: ext4 dev: /dev/sda8 
  ID-2: /home raw size: 55.88 GiB size: 54.75 GiB (97.98%) 
  used: 7.07 GiB (12.9%) fs: ext4 dev: /dev/sda9 
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 261 Uptime: 4h 11m Memory: 7.64 GiB used: 2.35 GiB (30.8%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38
  $ xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Nordic 2.4G Wireless Receiver Consumer Control	id=10	[slave  pointer  (2)]
⎜   ↳ Nordic 2.4G Wireless Receiver Mouse     	id=12	[slave  pointer  (2)]
⎜   ↳ Advanced Silicon S.A CoolTouch(TM) System	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Nordic 2.4G Wireless Receiver           	id=9	[slave  keyboard (3)]
    ↳ Nordic 2.4G Wireless Receiver System Control	id=11	[slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD: In         	id=14	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=15	[slave  keyboard (3)]
    ↳ Dell AIO WMI hotkeys                    	id=16	[slave  keyboard (3)]
    ↳ Nordic 2.4G Wireless Receiver Consumer Control	id=17	[slave  keyboard (3)]
    ↳ Keyboard              	id=18	[slave  keyboard (3)]

libinput debug-events
-event15  DEVICE_ADDED     Advanced Silicon S.A CoolTouch(TM) System seat0 default group7  cap:t  size 512x287mm ntouches 10 calib

-event15  TOUCH_DOWN       +11.767s	0 (0) 50.49/59.22 (258.50/170.22mm)
 event15  TOUCH_FRAME      +11.767s	
 event15  TOUCH_UP         +11.860s	
 event15  TOUCH_FRAME      +11.860s	

1 Like

Have you tried the fix detailed here?

1 Like

Just tried it but still get double-taps! Thanks though!

Dell has a pretty in-depth troubleshooting guide here:

I am not sure if this similar issue describes your experience or not:

Hi. I don't think this quite describes it - my issue is that a single tap registers a double-tap, .e.g. a folder will open instead of just being selected, or a context menu will pop up; and the cursor flickers like there have been multiple taps registered, etc.

Anyway, I think I may have got to the crux of the problem - touchegg. I have two processes running in the background, and stopping one of them brings the touchscreen functionality back to normal; one is a root process, the other (which I stopped) is a user process. Are there normally two processes running alongside each other? This is the default installation that comes with Zorin OS, by the way.

I'm not sure how best to proceed. What would happen if I remove (or at least, disable) touchegg altogether? Presumably that takes away gesture functionality (which I honestly don't care for on a desktop touchscreen, save for flick-to-scroll in a browser). Any pointers are welcome!

A screenshot of what's listed in my system monitor:

P. S. Well this is very odd. Just decided to apply the Firefox fix and rebooted, fully expecting to have to go and stop touchegg from the system monitor to get the touch functionality to work... but, the screen actually worked fine right off the bat, with touchegg running and all. Go figure.
Interestingly, I had enabled xinput2 before, and this is when I noticed the single-tapping issues. Gotta wait and observe I guess. So strange though. :woman_shrugging:

1 Like

Marked solution. 257

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.