Trouble installing Zorin Core 16 Windows 10 Pro

I have been trying to install Zorin Core 16 on a new Windows 10 Pro laptop.

Every time I switch the boot order in BIOS to USB I get a black screen instead of the Zorin installation screen.

Here is what I have done so far:

Turned on support for Linux Subsystem in Windows Features on/off.
Disabled Secure Boot and Fast Boot in BIOS.

I tried the USB on another computer running windows 10 and I got the installation screen, but for some reason it won't show up on the laptop.

Any help would be appreciated.

What graphics does the notebook computer have?

It has Intel UHD Graphics 600

The CPU is a 10th generation Intel Gemini Lake J4005

Fast boot is disabled from Within Windows, not BIOS. It is in the Control Panel, then Power Management... This should point you in the right direction... I do not remember exact instructions. A net search should help if you cannot find the setting, though.

I asked about graphics since that seemed a likely culprit given what you describe. But the Intel UHD 600 should work fine out of the box...
We may need to return to investigating graphics, though...

Disabled Fast Startup in gpedit.msc Computer Configuration \Administrative Templates \System \Shutdown

I still get a black screen on boot. When I press the power button off and on again the Intel logo screen comes up and freezes until I open BIOS to switch boot order back to windows.

@Rian42 , please see this thread:

Your situation is a bit different. From every piece of literature I can find, the
PCI 8086:3185:8086:2212
Class: 03-80
Vendor: Intel
Name: GeminiLake [UHD Graphics 600]
Works, on Ubuntu 21.04 and all others.
Except one... Fedora 34; this card fails on.
Fedora should have run on a range between 5.15 and 5.17 and maybe 5.17 kernels...
But it is possible that that one time it was tested, it was tested on a 5.13 kernel. Impossible to know...

The feedback that you and @noe can provide may be very Helpful to the ZorinGroup, if we do establish that the current 5.13.0-30 kernel is the actual culprit.
It depends on your willingness to jump through a couple hoops... To install Zorin, then immediately change to the 5.16 or 5.8 kernels, both known to work (For the 600, that is...). Or the Ubuntu 20.04 OEM kernel...

I would be willing to help.

Since I am new to Linux I may need to be walked through the steps.

I consider myself new to Linux, though I am about two years in, now...

And I would need to be walked through the steps, too. I have never installed Zorin without using the Ubiquity installer... So, I must learn how to do it.
Let me do such and I will post back in some odd hours... or a day...

Are you still able to help with Zorin Core installation?

I am very behind schedule on this... sorry to take so long.

Could be just UEFI issue. Verify that your boot USB is configured for UEFI.

You could use Ventoy ( to prepare your USB drive for this, then you just copy the ISO images on to the USB drive.

1 Like

Tried USB with Ventoy, still got a black screen. But this time there is a small white line in the top left corner, can't type anything though.

I've tried installing with Rufus, I have tried with Balena, I even tried installing the latest version of Pop! OS, but I cannot get the installation screen to come up after USB is selected in BIOS.

Just as a test, can you try the installer for Zorin 15.3?
This way we can confirm if it is kernel graphics drivers.

Select a mirror if needed.

Tried 15.3 with Ventoy and Rufus, still getting a black screen with small white line at the top left.

This tells me that my hypothesis may be incorrect.
You might try the Zorin 16 install with CSM (Compatibility Support Module) EFI boot.
Or try booting as Legacy (MBR - Master Boot Record).

Sadly... this can also indicate HDD or Board failure. While I would not consider this the Likeliest possibility - it is worth noting and filing away for later.
If you have Windows on the machine, and if it boots - this actually improves your odds. and you may try using the on-board startup diagnostic tool.

CSM boot mode does not appear in BIOS for me.

What about Legacy?

Legacy was already enabled when I first used BIOS.

Hmmm... reallly... and was the USB stick booting as UEFI?