Trouble Printing-troubleshooter says "cups-pki-expired"

I'm currently running Zorin 15.3. Yesterday, when I tried to print, I noticed that print jobs were stuck not processing. Software updater says everything is up to date. After considerable searching and multiple reboots of everything with no changes, I finally found the troubleshooter says "cups-pki-expired". Searching this error only turns up one small thread on the problem, which I started trying to follow. The solution talks about rolling the version of cups back one notch. Fine, I'll see what version of CUPS I'm running. If I look at the installed software listing, it doesn't include cups. Command line "apt policy cups" gives me 2.2.7-lubuntu2.9. If I go to the software installer tool, the latest version is 2.4.2-5.

OK, now I'm totally confused with no idea of how to progress. If I install cups explicitly to the current version out of the software selector, is that going to foul things up? Why am I running an outdated version of cups when my software is up to date and I don't even have it installed?

Most of the commands for editing preferences in cups point to file locations that don't exist on my machine (/var, /etc), and searches for the file names that some threads say to examine or edit doesn't return anything. I've got very little understanding for running Linux from the command line, but if I can find a command spelled out that sounds like it won't brick my system, I can run it. Any ideas?

Well, thanks to all the solutions suggested here, I went ahead and tried installing the newest version of cups from the software repository. It says it installed but I can't find it explicitly accessible on my machine. I've rebooted again since doing that, and still no printing, with the same error, "cups-pki-expired". I ran through the troubleshooter again and it fails to resolve the problem. I couldn't find a way to attach my troubleshooting log as a file here, so I'll past its text below. I've continued searching elsewhere on the internet and can't find any comprehensible solution to get my printer functioning. As a novice linux user, the lack of printing support has to be the biggest problem I see and is the reason I won't recommend others try linux systems.

Page 1 (<troubleshoot.SchedulerNotRunning.SchedulerNotRunning object at 0x7fcfba386fd0>):
{'cups_connection_failure': False}
Page 2 (<troubleshoot.ChoosePrinter.ChoosePrinter object at 0x7fcfba39f898>):
{'cups_dest': <cups.Dest EPSON_WF_7620_Series (default)>,
'cups_instance': None,
'cups_queue': 'EPSON_WF_7620_Series',
'cups_queue_listed': True}
Page 3 (<troubleshoot.CheckPrinterSanity.CheckPrinterSanity object at 0x7fcfba386f60>):
{'cups_device_uri_scheme': 'ipps',
'cups_printer_dict': {'device-uri': 'ipps://EPSON372CBD.local:631/ipp/print',
'printer-info': 'EPSON_WF_7620_Series',
'printer-is-shared': False,
'printer-location': '',
'printer-make-and-model': 'WF-7620 Series',
'printer-state': 3,
'printer-state-message': '',
'printer-state-reasons': ['cups-pki-expired'],
'printer-type': 2240604,
'printer-uri-supported': 'ipp://localhost/printers/EPSON_WF_7620_Series'},
'cups_printer_remote': False,
'is_cups_class': False,
'local_cups_queue_attributes': {'charset-configured': 'utf-8',
'charset-supported': ['us-ascii', 'utf-8'],
'color-supported': True,
'compression-supported': ['none', 'gzip'],
'copies-default': 1,
'copies-supported': (1, 9999),
'cups-version': '2.2.7',
'device-uri': 'ipps://EPSON372CBD.local:631/ipp/print',
'document-format-default': 'application/octet-stream',
'document-format-supported': ['application/octet-stream',
'application/pdf',
'application/postscript',
'application/vnd.adobe-reader-postscript',
'application/vnd.cups-pdf',
'application/vnd.cups-pdf-banner',
'application/vnd.cups-postscript',
'application/vnd.cups-raster',
'application/vnd.cups-raw',
'application/x-cshell',
'application/x-csource',
'application/x-perl',
'application/x-shell',
'image/gif',
'image/jpeg',
'image/png',
'image/pwg-raster',
'image/tiff',
'image/urf',
'image/x-bitmap',
'image/x-photocd',
'image/x-portable-anymap',
'image/x-portable-bitmap',
'image/x-portable-graymap',
'image/x-portable-pixmap',
'image/x-sgi-rgb',
'image/x-sun-raster',
'image/x-xbitmap',
'image/x-xpixmap',
'image/x-xwindowdump',
'text/css',
'text/html',
'text/plain'],
'finishings-default': 3,
'finishings-supported': [3],
'generated-natural-language-supported': ['en-us'],
'ipp-features-supported': ['subscription-object'],
'ipp-versions-supported': ['1.0',
'1.1',
'2.0',
'2.1'],
'ippget-event-life': 15,
'job-cancel-after-default': 10800,
'job-cancel-after-supported': (0, 2147483647),
'job-creation-attributes-supported': ['copies',
'finishings',
'ipp-attribute-fidelity',
'job-hold-until',
'job-name',
'job-priority',
'job-sheets',
'media',
'media-col',
'multiple-document-handling',
'number-up',
'output-bin',
'orientation-requested',
'page-ranges',
'print-color-mode',
'print-quality',
'printer-resolution',
'sides'],
'job-hold-until-default': 'no-hold',
'job-hold-until-supported': ['no-hold',
'indefinite',
'day-time',
'evening',
'night',
'second-shift',
'third-shift',
'weekend'],
'job-ids-supported': True,
'job-k-limit': 0,
'job-k-octets-supported': (0, 1921724608),
'job-page-limit': 0,
'job-priority-default': 50,
'job-priority-supported': [100],
'job-quota-period': 0,
'job-settable-attributes-supported': ['copies',
'finishings',
'job-hold-until',
'job-name',
'job-priority',
'media',
'media-col',
'multiple-document-handling',
'number-up',
'output-bin',
'orientation-requested',
'page-ranges',
'print-color-mode',
'print-quality',
'printer-resolution',
'sides'],
'job-sheets-default': ('none', 'none'),
'job-sheets-supported': ['none',
'classified',
'confidential',
'form',
'secret',
'standard',
'topsecret',
'unclassified'],
'jpeg-k-octets-supported': (0, 1921724608),
'jpeg-x-dimension-supported': (0, 65535),
'jpeg-y-dimension-supported': (1, 65535),
'marker-change-time': 1671588385,
'marker-colors': ['#000000',
'#00FFFF',
'#FF00FF',
'#FFFF00'],
'marker-high-levels': [100, 100, 100, 100],
'marker-levels': [50, 100, 41, 100],
'marker-low-levels': [15, 15, 15, 15],
'marker-names': ['Black ink',
'Cyan ink',
'Magenta ink',
'Yellow ink'],
'marker-types': ['ink-cartridge',
'ink-cartridge',
'ink-cartridge',
'ink-cartridge'],
'media-bottom-margin-supported': [300],
'media-col-default': '(unknown IPP value tag '
'0x34)',
'media-col-supported': ['media-bottom-margin',
'media-left-margin',
'media-right-margin',
'media-size',
'media-source',
'media-top-margin',
'media-type'],
'media-default': 'na_letter_8.5x11in',
'media-left-margin-supported': [360],
'media-right-margin-supported': [360],
'media-size-supported': ['(unknown IPP value '
'tag 0x34)',
'(unknown IPP value '
'tag 0x34)',
'(unknown IPP value '
'tag 0x34)',
'(unknown IPP value '
'tag 0x34)',
'(unknown IPP value '
'tag 0x34)',
'(unknown IPP value '

Sorry, it didn't get the whole troubleshooter file, here's the rest:

                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)',
                                                      '(unknown IPP value '
                                                      'tag 0x34)'],
                             'media-source-supported': ['auto',
                                                        'main',
                                                        'alternate',
                                                        'rear'],
                             'media-supported': ['na_letter_8.5x11in',
                                                 'na_index-4x6_4x6in',
                                                 'na_5x7_5x7in',
                                                 'na_govt-letter_8x10in',
                                                 'na_super-b_13x19in',
                                                 'iso_a3_297x420mm',
                                                 'iso_a4_210x297mm',
                                                 'iso_a6_105x148mm',
                                                 'na_ledger_11x17in',
                                                 'na_legal_8.5x14in',
                                                 'na_invoice_5.5x8.5in',
                                                 'oe_photo-l_3.5x5in',
                                                 'na_number-10_4.125x9.5in'],
                             'media-top-margin-supported': [300],
                             'media-type-supported': ['stationery',
                                                      'photographic-high-gloss',
                                                      'photographic',
                                                      'photographic-semi-gloss',
                                                      'photographic-glossy',
                                                      'photographic-matte',
                                                      'stationery-preprinted',
                                                      'stationery-letterhead',
                                                      'stationery-colored',
                                                      'stationery-heavyweight',
                                                      'envelope'],
                             'multiple-document-handling-supported': ['separate-documents-uncollated-copies',
                                                                      'separate-documents-collated-copies'],
                             'multiple-document-jobs-supported': True,
                             'multiple-operation-time-out': 300,
                             'multiple-operation-time-out-action': 'process-job',
                             'natural-language-configured': 'en-us',
                             'notify-attributes-supported': ['printer-state-change-time',
                                                             'notify-lease-expiration-time',
                                                             'notify-subscriber-user-name'],
                             'notify-events-default': ['job-completed'],
                             'notify-events-supported': ['job-completed',
                                                         'job-config-changed',
                                                         'job-created',
                                                         'job-progress',
                                                         'job-state-changed',
                                                         'job-stopped',
                                                         'printer-added',
                                                         'printer-changed',
                                                         'printer-config-changed',
                                                         'printer-deleted',
                                                         'printer-finishings-changed',
                                                         'printer-media-changed',
                                                         'printer-modified',
                                                         'printer-restarted',
                                                         'printer-shutdown',
                                                         'printer-state-changed',
                                                         'printer-stopped',
                                                         'server-audit',
                                                         'server-restarted',
                                                         'server-started',
                                                         'server-stopped'],
                             'notify-lease-duration-default': 86400,
                             'notify-lease-duration-supported': (0,
                                                                 2147483647),
                             'notify-max-events-supported': [100],
                             'notify-pull-method-supported': ['ippget'],
                             'notify-schemes-supported': ['dbus',
                                                          'mailto',
                                                          'rss'],
                             'number-up-default': 1,
                             'number-up-supported': [1, 2, 4, 6, 9, 16],
                             'operations-supported': [2,
                                                      4,
                                                      5,
                                                      6,
                                                      8,
                                                      9,
                                                      10,
                                                      11,
                                                      12,
                                                      13,
                                                      16,
                                                      17,
                                                      18,
                                                      19,
                                                      20,
                                                      21,
                                                      22,
                                                      23,
                                                      24,
                                                      25,
                                                      26,
                                                      27,
                                                      28,
                                                      34,
                                                      35,
                                                      37,
                                                      38,
                                                      56,
                                                      57,
                                                      59,
                                                      16385,
                                                      16386,
                                                      16387,
                                                      16388,
                                                      16389,
                                                      16390,
                                                      16391,
                                                      16392,
                                                      16393,
                                                      16394,
                                                      16395,
                                                      16396,
                                                      16397,
                                                      16398,
                                                      16399,
                                                      16423,
                                                      14],
                             'orientation-requested-default': 6,
                             'orientation-requested-supported': [3,
                                                                 4,
                                                                 5,
                                                                 6],
                             'output-bin-default': 'face-up',
                             'output-bin-supported': ['face-up'],
                             'page-ranges-supported': True,
                             'pages-per-minute': 1,
                             'pages-per-minute-color': 1,
                             'pdf-k-octets-supported': (0, 1921724608),
                             'pdf-versions-supported': ['adobe-1.2',
                                                        'adobe-1.3',
                                                        'adobe-1.4',
                                                        'adobe-1.5',
                                                        'adobe-1.6',
                                                        'adobe-1.7',
                                                        'iso-19005-1_2005',
                                                        'iso-32000-1_2008',
                                                        'pwg-5102.3'],
                             'pdl-override-supported': ['attempted'],
                             'port-monitor': 'none',
                             'port-monitor-supported': ['none'],
                             'print-color-mode-default': 'color',
                             'print-color-mode-supported': ['monochrome',
                                                            'color'],
                             'print-quality-default': 4,
                             'print-quality-supported': [4],
                             'printer-commands': 'none',
                             'printer-config-change-date-time': '(IPP_TAG_DATE)',
                             'printer-config-change-time': 1673095389,
                             'printer-current-time': '(IPP_TAG_DATE)',
                             'printer-dns-sd-name': None,
                             'printer-error-policy': 'retry-job',
                             'printer-error-policy-supported': ['abort-job',
                                                                'retry-current-job',
                                                                'retry-job',
                                                                'stop-printer'],
                             'printer-geo-location': '(unknown IPP value '
                                                     'tag 0x12)',
                             'printer-get-attributes-supported': ['document-format'],
                             'printer-icons': 'http://localhost/icons/EPSON_WF_7620_Series.png',
                             'printer-info': 'EPSON_WF_7620_Series',
                             'printer-is-accepting-jobs': True,
                             'printer-is-shared': False,
                             'printer-is-temporary': False,
                             'printer-location': '',
                             'printer-make-and-model': 'WF-7620 Series',
                             'printer-more-info': 'http://localhost/printers/EPSON_WF_7620_Series',
                             'printer-name': 'EPSON_WF_7620_Series',
                             'printer-op-policy': 'default',
                             'printer-op-policy-supported': ['authenticated',
                                                             'default',
                                                             'kerberos'],
                             'printer-organization': '',
                             'printer-organizational-unit': '',
                             'printer-resolution-default': (300, 300, 3),
                             'printer-resolution-supported': [(300,
                                                               300,
                                                               3)],
                             'printer-settable-attributes-supported': ['printer-geo-location',
                                                                       'printer-info',
                                                                       'printer-location',
                                                                       'printer-organization',
                                                                       'printer-organizational-unit'],
                             'printer-state': 3,
                             'printer-state-change-date-time': '(IPP_TAG_DATE)',
                             'printer-state-change-time': 1674310046,
                             'printer-state-message': '',
                             'printer-state-reasons': ['cups-pki-expired'],
                             'printer-type': 2240604,
                             'printer-up-time': 1674311352,
                             'printer-uri-supported': ['ipp://localhost/printers/EPSON_WF_7620_Series'],
                             'printer-uuid': 'urn:uuid:3261301c-55e1-3745-7e6d-f3ebbc66487f',
                             'pwg-raster-document-resolution-supported': [(300,
                                                                           300,
                                                                           3)],
                             'pwg-raster-document-sheet-back': 'normal',
                             'pwg-raster-document-type-supported': ['black_1',
                                                                    'sgray_8',
                                                                    'srgb_8'],
                             'queued-job-count': 0,
                             'server-is-sharing-printers': False,
                             'sides-default': 'one-sided',
                             'sides-supported': ['one-sided',
                                                 'two-sided-long-edge',
                                                 'two-sided-short-edge'],
                             'uri-authentication-supported': ['requesting-user-name'],
                             'uri-security-supported': ['none'],
                             'which-jobs-supported': ['completed',
                                                      'not-completed',
                                                      'aborted',
                                                      'all',
                                                      'canceled',
                                                      'pending',
                                                      'pending-held',
                                                      'processing',
                                                      'processing-stopped']}}

Page 4 (<troubleshoot.CheckPPDSanity.CheckPPDSanity object at 0x7fcfba3b0160>):
{'cups_printer_ppd_defaults': {'General': {'ColorModel': 'RGB',
'Duplex': 'None',
'InputSlot': 'Rear',
'MediaType': 'Stationery',
'PageRegion': 'Letter',
'PageSize': 'Letter',
'cupsPrintQuality': 'Normal'}},
'cups_printer_ppd_valid': True,
'missing_pkgs_and_exes': ([], [])}
Page 5 (<troubleshoot.LocalOrRemote.LocalOrRemote object at 0x7fcfba3b0e10>):
{'printer_is_remote': False}
Page 6 (<troubleshoot.PrinterStateReasons.PrinterStateReasons object at 0x7fcfba345c50>):
{'printer-state-message': '', 'printer-state-reasons': ['cups-pki-expired']}
Page 7 (<troubleshoot.PrintTestPage.PrintTestPage object at 0x7fcfba350f28>):
{'test_page_attempted': '21/Jan/2023:09:29:35 -0500',
'test_page_job_id': [414],
'test_page_job_status': [(True,
414,
'EPSON_WF_7620_Series',
'Test Page',
'Pending',
{'attributes-charset': 'utf-8',
'attributes-natural-language': 'en-us',
'date-time-at-completed': None,
'date-time-at-creation': '(IPP_TAG_DATE)',
'date-time-at-processing': '(IPP_TAG_DATE)',
'document-format': 'application/vnd.cups-pdf-banner',
'document-format-detected': 'application/vnd.cups-pdf-banner',
'job-hold-until': 'no-hold',
'job-id': 414,
'job-impressions-completed': 1,
'job-k-octets': 1,
'job-media-progress': 0,
'job-media-sheets-completed': 1,
'job-more-info': 'http://localhost/jobs/414',
'job-printer-state-message': '',
'job-printer-state-reasons': ['cups-pki-expired',
'paused'],
'job-printer-up-time': 1674311397,
'job-printer-uri': 'ipp://localhost/printers/EPSON_WF_7620_Series',
'job-priority': 50,
'job-sheets': ['none', 'none'],
'job-state': 3,
'job-state-reasons': 'printer-stopped',
'job-uri': 'ipp://localhost/jobs/414',
'job-uuid': 'urn:uuid:346432ae-750c-3afd-7705-a9ed060a2c31',
'number-of-documents': 1,
'orientation-requested': 6,
'printer-uri': 'ipp://localhost/printers/EPSON%5FWF%5F7620%5FSeries',
'time-at-completed': None,
'time-at-creation': 1674311375,
'time-at-processing': 1674311375})],
'test_page_successful': False}
Page 8 (<troubleshoot.PrinterStateReasons.PrinterStateReasons object at 0x7fcfba35bc18>):
{'printer-state-message': '',
'printer-state-reasons': ['cups-pki-expired', 'paused']}
Page 9 (<troubleshoot.Locale.Locale object at 0x7fcfba35bf60>):
{'printer_page_size': 'Letter',
'system_locale_lang': None,
'user_locale_ctype': 'en_US',
'user_locale_messages': 'en_US'}

Is this any good to you:

I went through that and was unable to get my printer running. I'm now trying to download new print drivers from Epson and get them installed. I may be getting closer, as it now seems to want to print, but I can't get control of the paper source (WF-7620 is a 2-tray printer). Even though I've downloaded and installed the new drivers, I suspect that when I go to set up a new printer, it's getting a generic driver file and not the ones I want it to use.

Well, I think that I got my printer back up and working. As near as I can deduce from all of the research I've done, the "cups-pki-expired" error indicates that some hidden certificate ID on the printer driver is older than Cups wants. I was unable to successfully implement any solution that told Cups to ignore this date issue. Printer drivers apparently aren't monitored by the software updater and neither check for updates nor tell you when an update is available.

Epson does have Linux drivers available for my WF-7620. The Epson driver download page has several different files available, as mine is a multifunction machine. For printing, I downloaded the "ESC/P-R Driver (generic driver)" and "Epson Printer Utility" packages. Once you accept the software license agreement, you are given a choice of several files to download. There is no explicit definition of what each file is really for. Per what I found, for Zorin and other Ubuntu based linux distros, you want the "_amd64.deb" file, regardless of what type of processor your computer has (I have an Intel). I installed both of these.

Once I installed these packages, I added a new printer. I accepted the downloaded driver that it finds during the setup process. I tried going into the printer properties and explicitly pointing to the .ppd file for my printer, but this doesn't work. Every time I do this, I get an error saying "No Such File Or Directory" even though I have manually verified that the file exists on my machine.

The "print test page" function doesn't work correctly for me. I have the printer configured either to auto choose the drawer or use the main drawer, and for letter size paper. Every time I try to send the test job, it wants to pull from drawer 2, which I have configured for 11x17 paper, so I get an error at the printer. If I bypass that and let it print onto the wrong paper, the test print seems correct. Despite that mismatch, it seemed to print a PDF file correctly, pulling the right paper, so I guess this is a "successful" printer install. I'm still not sure I have full control over all printer functionality (2-drawer printer, two sided printing, etc.) but it's functional enough for now.

This process took WAY too many hours and too much of my patience. I'm writing up this detailed a description of what I did and how I solved this to hopefully save others some of the lost time and effort in trying to resolve this issue.

1 Like

Appreciate you doing that to help others.
Is your printer a EPSON WF7620 or other?
It would be good to add to title of the thread to aid searches.

I have an Epson printer that worked with Zorin out of the box, but I am aware of fun and games encountered by some other users when it comes to printing and scanning.