Troubleshooting Installing Steam on Zorin OS 16

image
going to to this

1 Like

Did it work?

No , it didn't work

After that i installed steam from store , but
This time i selected source "flatpack"
Instead of "zorin os"

And Flatpak worked?

Yes , tht worked

And i noticed that , flatpack steam file is of ~800mb ... And zorin steam file of of 4mb nearly coz zorin system file contain steam files but they are not working,
Means now i have two file of steam
One is inbuilt in system which is not working
And another tht i downloaded from flatpack source - and is working fine

Interesting.
I also finally gave up apt install of Spotify.
Currently running Flatpak version with no issue.
I started to see Flatpak as a necessary evil...

1 Like

Considering how often Flatpak fails and a person must turn to APT or a .deb package...

Strange both Spotify and Steam PPA/.deb works for me. Wonder what makes the different?

1 Like

Yes, I had no trouble with Steam, either. But I did not add a Repository for it.

I think if there is one major problem with Linux installations; it is the prevalence of outdated "guides" bounding all over the internet.

1 Like

That is very curious.
But since I have to reinstall the system when Zorin 16 is released, I am not going to look into this issue any further.

nice guide, first time no issues on Ubuntu based distros while installing Steam :slight_smile:

1 Like

Try using synaptic to fix broken install. I'm sure your holding broken packages, that's why some of the dependencies weren't installed.