Ubuntu install not recognzing windows 10 hard drive but gparted and fdisk recognizies

Im trying to dual boot ubuntu(zorin 16) and i hav don i before too but i ended up deleting it. It still shows up in the boot menu as ubuntu tho. When i launch it it just shows a very minimal bash screen. Anyways getting back to the point when im trying to select the option in which i use limux alongside windows it only shows my live cd drive but not my hdd even tho my hdd shows up in gparted and fdisk. When i try to do the 3rd option that is configuring the partitions myself it shows my hard drive but it says 0mb is used even tho ive used more than 500gb of 1tb. I cant figure put whats the issue…

In Windows, can you go to the Control Panel, then power settings and ensure that Fast Startup or Fast Boot is Disabled.
the hard drive will not be seen if those are enabled.

Bro in my laptop both Fast Startup or Fast Boot is enabled. I didn't face problem like this.

It must be disabled.
The Windows Fast Boot locks the hard drive, preventing read / write access.

1 Like

Ok bro I will disable it.

As i have mentioned i installed zorin before painlessly without doing any of this. I also dont have admin access on windows so i probably cant change it. Is it possible to do without admin access? I suspect it might have something to do with that extra ubuntu profile in the bios menu aside from livecd and windows which just takes me to grub if i try to open it.

There are several factors;
Fast Boot may have been disabled already before.
If you were using a different computer at that time, it may have had a different Drive (HDD instead of nVME or eMMC)... Do you know if you are using nVME or eMMC SSD at this time? Is your bios set to RAID or AHCI?

i have a single hdd drive. fast boot HAS been disabled before but its enabled again after resetting windows. im not sure what raid or ahci means. i installed zorin on the same computer. anyways how do i remove that extra ubuntu in the bios menu that just boots to grub? maybe that would fix it.

On further inspection it IS because of fast-boot. Ig ill have to disable that for sure no other way…
On the other hand i have 2 new issues
1 delete the extra Ubuntu
2 skip filecheck and go directly to try zorin
2nd one is cuz whenever i do ctrl c it doesnt work but for other distros it works. So is there a way to skip that completely?
Also is it possible to save progress in the livecd as i want to run it completely portably. My laptop crashes often during meetings and i want the usb as a backup. However each time i have to reinstall apps and aign in again…

Yes, you can run with persistence to achieve this. I recommend Ventoy highly for this. It allows a bit more freedom in Persistent Distro Use.

This sounds like information that is stored in the EFI partition, to me. This may be trickier, since Zorin OS will show up as Ubuntu in this field.
An option may be to simply re-install Zorin OS as normal after removing all Ubuntu entries.
Boot LiveUSB, then open a terminal and run efibootmgr
This will list all boot entries in the EFI partition. It should look similar to mine:

BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0004,0006
Boot0000* ubuntu
Boot0004* MATSHITA DVD-RAM SW830
Boot0004_BbsIndex* 
Boot0006  ST2000DM008-2FR102
Boot0006_BbsIndex  
Bootffff_BbsIndex* 

In my case, if I wanted to remove the Zorin Boot entry, I would focus on Boot0000. You only need the last number of the boot identifier...
So in terminal, I would run this to remove that entry:

efibootmgr -b 0 -B

Let's say that it showed Ubuntu as Boot0003:

efibootmgr -b 3 -B

This can be done by editing grub and adding the parameter fsck.mode=skip just before "quiet splash":

GRUB_CMDLINE_LINUX_DEFAULT="fsck.mode=skip quiet splash"

Removing that is much easier using CMD in Windows, by the way.

Oh I dunno... I just listed Two Short Commands to do it in Linux.
In windows cmd prompt it is two short commands. I would say that it is exactly the same in either.

1 Like

A post was split to a new topic: Windows + Linux boots only to Windows

Searched up peristance and saw this https://www.howtogeek.com/howto/14912/create-a-persistent-bootable-ubuntu-usb-flash-drive/
Ir recommended rufus and I already used rufus only for zorin. How do i ‘activate’ persistence?

I have never used Rufus, so I am not sure off-hand.

You're a real chad u replied in seconds tysm!

1 Like

How to edit grub? Also isn't it a bug that it doesn't skip when ctrl+c’d? Its been there from zorin 15 ime.

There are two methods of editing grub:

  • Edit grub on the LiveUSB
  • Edit grub on an installed distro

To edit grub on a LiveUSB, from the boot menu (Grub Menu), tap the e key to edit the editor. There should be a visible prompt on the bottom of the window letting you know that you can tap the e key, so you will know tha tis the screen to tap that key in.

On an installed system, open a terminal and run

sudo nano /etc/default/grub

To open the file in the terminal editor
OR
use the GUI with

sudo -i

To elevate to root privileges, then open the text editor

nautilus

Navigate to "other locations" > "computer" then to /etc/default and double click the grub file to open it in a text editor.